Skip to content

← Actionable
High, CVSS 8.8amended

Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization

CVE-2026-114135GHSA-354v-3q48-cv69

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-114135: 0.48% estimated exploitation activity in the next 30 days; percentile 41.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Jupyter Server's gateway WebSocket handler checks that a user is authenticated, but it does not ask the configured Authorizer whether that user may execute kernels. In Jupyter Server 2.0.0 through 2.5.0, enabling GatewayClient.url automatically replaced the normal kernel channel handler with this gateway-specific handler. An authenticated user who is denied the execute action on the kernels resource can therefore still open a kernel channel and send messages to the upstream kernel. Details The normal handler performs the expected authorization check before creating the WebSocket connection: https://github.com/jupyter-server/jupyterserver/blob/v2.5.0/jupyterserver/services/kernels/websocket.py#L39-L47 The gateway handler only checks currentuser and then opens the upstream channel. It never calls authorizer.isauthorized(...): https://github.com/jupyter-server/jupyterserver/blob/v2.5.0/jupyterserver/gateway/handlers.py#L49-L75…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-354v-3q48-cv69

  2. Revision 2 · amended ·

    Amended from osv record GHSA-354v-3q48-cv69

  3. Revision 1 · created ·

    Published from ghsa record GHSA-354v-3q48-cv69

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114135

Advisory: Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization
IDs: CVE-2026-114135, GHSA-354v-3q48-cv69
Record: https://patchnext.com/advisories/cve-2026-114135 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyter-server: affected >= 2.0.0, < 2.6.0; fixed in 2.6.0

## Suggested inspection (read-only)
- `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyter-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-354v-3q48-cv69 (GitHub-reviewed advisory GHSA-354v-3q48-cv69 lists affected ranges: PyPI jupyter-server >=2.0.0 <2.6.0)
- Verified: https://osv.dev/vulnerability/GHSA-354v-3q48-cv69 (OSV record GHSA-354v-3q48-cv69 lists affected ranges: PyPI jupyter-server >=2.0.0 <2.6.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…