Skip to content

← Actionable
High, CVSS 8.7amended

Black: GitHub Action installs unvalidated required-version from pyproject.toml

CVE-2026-114134GHSA-cg8m-r9f2-5wm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (black 26.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI black

    Affected
    < 26.10.1
    Fixed in
    26.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The GitHub Action bundled with Black can read the version from tool.black.required-version if usepyproject is set to True. This version is not validated and therefore can be used to execute untrusted code in the context of a victim's repository. Details This is similar to the previous CVE-2026-31900. The value in tool.black.required-version is accepted as the version to be installed by the action without validation. Proof of concept Reproduction requires a victim to use Black's GitHub Action with usepyproject: true. The attacker would then issue a PR to the victim's repository with pyproject.toml edited so that Black points to a malicious repository. Impact This is a remote code execution vulnerability impacting users using the GitHub Action bundled with psf/black and using the usepyproject: true setting.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-cg8m-r9f2-5wm2

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-cg8m-r9f2-5wm2

  3. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  4. Revision 2 · amended ·

    Amended from osv record GHSA-cg8m-r9f2-5wm2

  5. Revision 1 · created ·

    Published from ghsa record GHSA-cg8m-r9f2-5wm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114134

Advisory: Black: GitHub Action installs unvalidated required-version from pyproject.toml
IDs: CVE-2026-114134, GHSA-cg8m-r9f2-5wm2
Record: https://patchnext.com/advisories/cve-2026-114134 (revision 5, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: black 26.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI black: affected < 26.10.1; fixed in 26.10.1

## Suggested inspection (read-only)
- `python -m pip show black`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on black.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cg8m-r9f2-5wm2 (GitHub-reviewed advisory GHSA-cg8m-r9f2-5wm2 lists affected ranges: PyPI black >=0 <26.10.1)
- Verified: https://osv.dev/vulnerability/GHSA-cg8m-r9f2-5wm2 (OSV record GHSA-cg8m-r9f2-5wm2 lists affected ranges: PyPI black >=0 <26.10.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…