uv vulnerable to arbitrary file deletion through RECORD entries
CVE-2026-114110GHSA-pjjw-68hj-v9mw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uv 0.11.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI uv
- Affected
- <= 0.11.5
- Fixed in
- 0.11.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pjjw-68hj-v9mw lists affected ranges: PyPI uv >=0 <0.11.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pjjw-68hj-v9mw lists affected ranges: PyPI uv >=0 <=0.11.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-114110: 0.35% estimated exploitation activity in the next 30 days; percentile 28.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Wheel RECORD entries can contain relative paths that traverse outside of the wheel’s installation prefix. In versions 0.11.5 and earlier of uv, these wheels were not rejected on installation and the RECORD was respected without validation on uninstall. uv uses the RECORD to determine files to remove on uninstall. Consequently, a malicious or malformed wheel could induce deletion of arbitrary files outside of the wheel’s installation prefix on uninstall. uv does not use the RECORD file to determine wheel file paths. Invalid RECORD entries cannot be used to create or modify files in arbitrary locations. Standards-compliant Python packaging tooling does not produce RECORD files that exhibit this behavior; an attacker must manually manipulate the RECORD. A user must install and uninstall the malformed wheel to be affected. An attack must guess the depth of the installation prefix path in order to target system files. Absolute paths in RECORD files are not allowed by the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-pjjw-68hj-v9mw
- Revision 3 · amended ·
Amended from ghsa record GHSA-pjjw-68hj-v9mw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-pjjw-68hj-v9mw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114110 Advisory: uv vulnerable to arbitrary file deletion through RECORD entries IDs: CVE-2026-114110, GHSA-pjjw-68hj-v9mw Record: https://patchnext.com/advisories/cve-2026-114110 (revision 4, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uv 0.11.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI uv: affected <= 0.11.5; fixed in 0.11.6 ## Suggested inspection (read-only) - `python -m pip show uv`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pjjw-68hj-v9mw (OSV record GHSA-pjjw-68hj-v9mw lists affected ranges: PyPI uv >=0 <0.11.6 (fixed)) - Verified: https://github.com/advisories/GHSA-pjjw-68hj-v9mw (GitHub-reviewed advisory GHSA-pjjw-68hj-v9mw lists affected ranges: PyPI uv >=0 <=0.11.5) Commands are suggestions: review each one before running it.
Loading voting…