uv is vulnerable to arbitrary file write through entry point names
CVE-2026-114109GHSA-4gg8-gxpx-9rph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (uv 0.11.15; uv 0.11.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4gg8-gxpx-9rph lists affected ranges: PyPI uv >=0 =0 <0.11.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4gg8-gxpx-9rph lists affected ranges: PyPI uv >=0 =0 <0.11.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-114109: 0.38% estimated exploitation activity in the next 30 days; percentile 32.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In versions of uv prior to 0.11.15, when installing a distribution containing an entry point specification (under consolescripts or guiscripts), uv would place the generated entry point according to the given name even if doing so resulted in a path outside of the environment's scripts directory. A malicious wheel could use this to place an executable outside of the intended environment, including in a directory already present on the user's PATH. This could shadow or overwrite an existing executable and potentially result in unexpected code execution under the wheel's control, even if the wheel's installation environment was not explicitly added to PATH by the user. In order to exploit this vulnerability, the attacker must induce their target into installing a malicious wheel. Patches uv 0.11.15 and newer address this vulnerability. Users are encouraged to upgrade to 0.11.15. Workarounds There is no workaround other than upgrading to uv 0.11.15.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4gg8-gxpx-9rph
- Revision 1 · created ·
Published from osv record GHSA-4gg8-gxpx-9rph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114109 Advisory: uv is vulnerable to arbitrary file write through entry point names IDs: CVE-2026-114109, GHSA-4gg8-gxpx-9rph Record: https://patchnext.com/advisories/cve-2026-114109 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: uv 0.11.15; uv 0.11.15. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io uv: affected < 0.11.15; fixed in 0.11.15 - PyPI uv: affected < 0.11.15; fixed in 0.11.15 ## Suggested inspection (read-only) - crates.io uv: check the installed version with your package manager. - `python -m pip show uv`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on uv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4gg8-gxpx-9rph (OSV record GHSA-4gg8-gxpx-9rph lists affected ranges: PyPI uv >=0 =0 <0.11.15 (fixed)) - Verified: https://github.com/advisories/GHSA-4gg8-gxpx-9rph (GitHub-reviewed advisory GHSA-4gg8-gxpx-9rph lists affected ranges: PyPI uv >=0 =0 <0.11.15) Commands are suggestions: review each one before running it.
Loading voting…