SvelteKit : XSS via untrusted cache-control header in prerendered page
CVE-2026-114061GHSA-27mw-82g8-phjj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sveltejs/kit
- Affected
- < 3.0.0
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-27mw-82g8-phjj lists affected ranges: npm @sveltejs/kit >=0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-27mw-82g8-phjj lists affected ranges: npm @sveltejs/kit >=0 <3.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 0.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:N
- EPSS
- CVE-2026-114061: 0.21% estimated exploitation activity in the next 30 days; percentile 11.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Applications that prerender pages and use setHeaders to set a cache-control header from an untrusted source are vulnerable to cross-site scripting (XSS). SvelteKit inserts the header value into a <meta http-equiv="cache-control" tag without escaping it. An attacker who can influence this value at prerender time can break out of the content attribute and inject HTML or JavaScript into the generated page. The injected code can then execute when users visit the page. Patches The fix escapes the header value before inserting it into the generated HTML. Upgrade to @sveltejs/kit version 3.0.0 or later. Workarounds Avoid forwarding untrusted cache-control header values with setHeaders on prerendered pages. Use a fixed, trusted cache policy instead.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-27mw-82g8-phjj
- Revision 2 · amended ·
Amended from osv record GHSA-27mw-82g8-phjj
- Revision 1 · created ·
Published from ghsa record GHSA-27mw-82g8-phjj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114061 Advisory: SvelteKit : XSS via untrusted cache-control header in prerendered page IDs: CVE-2026-114061, GHSA-27mw-82g8-phjj Record: https://patchnext.com/advisories/cve-2026-114061 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated (CVSS 0.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sveltejs/kit: affected < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sveltejs/kit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-27mw-82g8-phjj (GitHub-reviewed advisory GHSA-27mw-82g8-phjj lists affected ranges: npm @sveltejs/kit >=0 <3.0.0) - Verified: https://osv.dev/vulnerability/GHSA-27mw-82g8-phjj (OSV record GHSA-27mw-82g8-phjj lists affected ranges: npm @sveltejs/kit >=0 <3.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…