Skip to content

← Actionable
Low, CVSS 2.1amended

SvelteKit: URL redirection to untrusted site via enhanced form submission

CVE-2026-114060GHSA-pfhg-q3qv-9q6r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sveltejs/kit 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-114060: 0.20% estimated exploitation activity in the next 30 days; percentile 10.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Applications using enhanced form actions (use:enhance) on routes that accept paths beginning with //, such as catch-all routes, may be vulnerable to an open redirect. Patches A fix has been prepared for @sveltejs/kit 3.0.0. Users should upgrade to 3.0.0 or later. The fix preserves leading double slashes in action paths without generating protocol-relative URLs, restricts non-redirect action navigation to the current origin, and includes the origin when comparing action locations with the current page. Workarounds Reject requests whose parsed URL pathname begins with // before route resolution, for example in a reverse proxy or a SvelteKit handle hook. Alternatively, disable navigation for non-redirect enhanced form results by supplying a custom submission callback: This applies non-redirect results to the current page instead of navigating to the action location.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from ghsa record GHSA-pfhg-q3qv-9q6r

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-pfhg-q3qv-9q6r

  3. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  4. Revision 2 · amended ·

    Amended from osv record GHSA-pfhg-q3qv-9q6r

  5. Revision 1 · created ·

    Published from ghsa record GHSA-pfhg-q3qv-9q6r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114060

Advisory: SvelteKit: URL redirection to untrusted site via enhanced form submission
IDs: CVE-2026-114060, GHSA-pfhg-q3qv-9q6r
Record: https://patchnext.com/advisories/cve-2026-114060 (revision 5, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @sveltejs/kit 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @sveltejs/kit: affected < 3.0.0; fixed in 3.0.0

## Suggested inspection (read-only)
- `npm ls @sveltejs/kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @sveltejs/kit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pfhg-q3qv-9q6r (GitHub-reviewed advisory GHSA-pfhg-q3qv-9q6r lists affected ranges: npm @sveltejs/kit >=0 <3.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-pfhg-q3qv-9q6r (OSV record GHSA-pfhg-q3qv-9q6r lists affected ranges: npm @sveltejs/kit >=0 <3.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…