Skip to content

← Actionable
High, CVSS 7.5amended

vLLM : DoS via unvalidated mm_processor_kwargs in multimodal image processors (Isaac, InternVL, H2OVL, etc.)

CVE-2026-114055GHSA-gx7p-2j49-hfq4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.31.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.7.3, < 0.31.0
    Fixed in
    0.31.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-114055: 0.42% estimated exploitation activity in the next 30 days; percentile 36.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary API clients can supply arbitrary mmprocessorkwargs per request. vLLM forwards these values through the multimodal rendering and processing pipeline to Hugging Face and custom image/video processor constructors and calls. Resource-sensitive values such as image size, patch size, patch count, crop count, or frame count can therefore be controlled by a remote client. For processors that upscale inputs, a single request can force an allocation large enough to terminate the API server or worker with an out-of-memory condition. Affected Components The per-request field was introduced in commit 041e29471671a3d43afedb6a749421d56ef4d3e7 and first shipped in v0.7.3. The generic forwarding path remains present in current main. The Isaac path is a concrete high-amplification example: - ChatCompletionRequest.mmprocessorkwargs - OnlineRenderer request extras - MMProcessorInputs.hfprocessormmkwargs - BaseMultiModalProcessor.info.gethfprocessor(hfprocessormmkwargs) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gx7p-2j49-hfq4

  2. Revision 2 · amended ·

    Amended from osv record GHSA-gx7p-2j49-hfq4

  3. Revision 1 · created ·

    Published from ghsa record GHSA-gx7p-2j49-hfq4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114055

Advisory: vLLM : DoS via unvalidated mm_processor_kwargs in multimodal image processors (Isaac, InternVL, H2OVL, etc.)
IDs: CVE-2026-114055, GHSA-gx7p-2j49-hfq4
Record: https://patchnext.com/advisories/cve-2026-114055 (revision 3, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.31.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.7.3, < 0.31.0; fixed in 0.31.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gx7p-2j49-hfq4 (GitHub-reviewed advisory GHSA-gx7p-2j49-hfq4 lists affected ranges: PyPI vllm >=0.7.3 <0.31.0)
- Verified: https://osv.dev/vulnerability/GHSA-gx7p-2j49-hfq4 (OSV record GHSA-gx7p-2j49-hfq4 lists affected ranges: PyPI vllm >=0.7.3 <0.31.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…