vLLM: Request-controlled mm_processor_kwargs.code_revision allows remote code execution
CVE-2026-114053GHSA-h3rc-6mm3-gc2m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.31.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.7.3, < 0.31.0
- Fixed in
- 0.31.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h3rc-6mm3-gc2m lists affected ranges: PyPI vllm >=0.7.3 <0.31.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h3rc-6mm3-gc2m lists affected ranges: PyPI vllm >=0.7.3 <0.31.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-114053: 0.46% estimated exploitation activity in the next 30 days; percentile 40.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An untrusted multimodal request can set `mm_processor_kwargs.code_revision`. When vLLM serves a model whose Hugging Face processor uses dynamic `auto_map` code and the operator enabled `--trust-remote-code`, this request value reaches `AutoProcessor.from_pretrained` and selects the Python revision imported by Transformers. This lets a client replace the operator-reviewed processor module with code from another revision of the same model repository. The operator-selected model/data `revision` remains pinned; only the executed processor code changes. Importing a Python module is arbitrary code execution in the vLLM API/renderer process. The PoC below demonstrates this with an import-time filesystem write. It is fully offline and does not require a GPU, model weights, or changes to a real Hub repository.
Affected snapshot - Repository: `vllm-project/vllm` - Verified commit:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-h3rc-6mm3-gc2m
- Revision 1 · created ·
Published from ghsa record GHSA-h3rc-6mm3-gc2m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114053 Advisory: vLLM: Request-controlled mm_processor_kwargs.code_revision allows remote code execution IDs: CVE-2026-114053, GHSA-h3rc-6mm3-gc2m Record: https://patchnext.com/advisories/cve-2026-114053 (revision 2, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.31.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.7.3, < 0.31.0; fixed in 0.31.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h3rc-6mm3-gc2m (OSV record GHSA-h3rc-6mm3-gc2m lists affected ranges: PyPI vllm >=0.7.3 <0.31.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h3rc-6mm3-gc2m (GitHub-reviewed advisory GHSA-h3rc-6mm3-gc2m lists affected ranges: PyPI vllm >=0.7.3 <0.31.0) Commands are suggestions: review each one before running it.
Loading voting…