vLLM: Forged multimodal UUID + P0/P1 processor-cache eviction drift: unauthenticated remote crash of the whole vLLM engine
CVE-2026-114050GHSA-p92p-rxj5-7p2x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.31.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- < 0.31.0
- Fixed in
- 0.31.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p92p-rxj5-7p2x lists affected ranges: PyPI vllm >=0 <0.31.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p92p-rxj5-7p2x lists affected ranges: PyPI vllm >=0 <0.31.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-114050: 0.20% estimated exploitation activity in the next 30 days; percentile 10.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multimodal content parts (imageurl, videourl, inputaudio, ...) accept a user-supplied uuid field that vLLM uses verbatim as the item's cache identity (mmhash). The two frontend/engine processor caches (P0 "sender" cache in the API process, P1 "receiver" cache in the EngineCore process) are independent LRU caches whose evictions are not synchronized, and the P1 hit path performs zero consistency validation — it silently substitutes the cached item's tensor data for whatever the current request actually contains. A single unauthenticated client can exploit this to kill the entire engine, deterministically, with default server flags: 1. Seed: send a small image with uuid="U". Both caches now map U to an item with NA visual tokens (e.g. 4). 2. Drift: send ~70 requests, each carrying a unique uuid, a max-size image, and an over-long text prompt. Each request is rejected with 400 — but after its image has been inserted into the P0 cache (insertion happens during chat rendering,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p92p-rxj5-7p2x
- Revision 2 · amended ·
Amended from osv record GHSA-p92p-rxj5-7p2x
- Revision 1 · created ·
Published from ghsa record GHSA-p92p-rxj5-7p2x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114050 Advisory: vLLM: Forged multimodal UUID + P0/P1 processor-cache eviction drift: unauthenticated remote crash of the whole vLLM engine IDs: CVE-2026-114050, GHSA-p92p-rxj5-7p2x Record: https://patchnext.com/advisories/cve-2026-114050 (revision 3, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.31.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected < 0.31.0; fixed in 0.31.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p92p-rxj5-7p2x (GitHub-reviewed advisory GHSA-p92p-rxj5-7p2x lists affected ranges: PyPI vllm >=0 <0.31.0) - Verified: https://osv.dev/vulnerability/GHSA-p92p-rxj5-7p2x (OSV record GHSA-p92p-rxj5-7p2x lists affected ranges: PyPI vllm >=0 <0.31.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…