Skip to content

← Actionable
High, CVSS 8.8

AgentCore CLI Bedrock Agent Import Vulnerable to Code Injection via Improper Triple-Quote Escaping

CVE-2026-11393GHSA-m4x6-gwgp-4pm7

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @aws/agentcore

    Affected
    >= 0.4.0, < 0.14.2>= 0.3.0-preview.7.0, <= 0.3.0-preview.9.0>= 1.0.0-preview.1, < 1.0.0-preview.9
    Fixed in
    1.0.0-preview.9, 0.14.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-11393: 0.34% estimated exploitation activity in the next 30 days; percentile 27.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The AgentCore CLI (@aws/agentcore) is a developer tool for managing agent infrastructure lifecycle on Amazon Bedrock AgentCore. An issue exists where, under certain circumstances, a crafted collaborationInstruction value stored in Bedrock Agent collaborator metadata can break out of a Python triple-quoted string in code generated by the agentcore add agent --type import command, resulting in arbitrary code execution when the generated file is loaded or deployed. Impact When a user runs agentcore add agent --type import to import a Bedrock supervisor agent that has multi-agent collaboration enabled, the CLI fetches collaborator metadata from the Bedrock API and interpolates the collaborationInstruction field directly into a triple-quoted Python string in the generated main.py file of the imported agent. Due to insufficient escaping, a collaborationInstruction value containing triple double-quote characters can terminate the string boundary and inject arbitrary Python…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m4x6-gwgp-4pm7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-11393

Advisory: AgentCore CLI Bedrock Agent Import Vulnerable to Code Injection via Improper Triple-Quote Escaping
IDs: CVE-2026-11393, GHSA-m4x6-gwgp-4pm7
Record: https://patchnext.com/advisories/cve-2026-11393 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: @aws/agentcore 1.0.0-preview.9, 0.14.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @aws/agentcore: affected >= 0.4.0, < 0.14.2; >= 0.3.0-preview.7.0, <= 0.3.0-preview.9.0; >= 1.0.0-preview.1, < 1.0.0-preview.9; fixed in 1.0.0-preview.9, 0.14.2

## Suggested inspection (read-only)
- `npm ls @aws/agentcore --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @aws/agentcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m4x6-gwgp-4pm7 (GitHub-reviewed advisory GHSA-m4x6-gwgp-4pm7 lists affected ranges: npm @aws/agentcore >=0.4.0 =0.3.0-preview.7.0 =1.0.0-preview.1 <1.0.0-preview.9)

Commands are suggestions: review each one before running it.

Loading voting…