Skip to content

← Actionable
Medium, CVSS 5.4amended

Electron: HID and USB permission checks can be attributed to the wrong origin

CVE-2026-113800GHSA-fw47-9c62-h3vw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 45.0.0-alpha.5, 44.3.0, 43.7.0, 42.11.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm electron

    Affected
    >= 45.0.0-alpha.1, < 45.0.0-alpha.5>= 44.0.0-alpha.1, < 44.3.0>= 43.0.0-alpha.1, < 43.7.0< 42.11.3
    Fixed in
    44.3.0, 45.0.0-alpha.5, 42.11.3, 43.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-113800: 0.24% estimated exploitation activity in the next 30 days; percentile 15.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact For hid and usb permission checks made from an iframe, session.setPermissionCheckHandler was given the top-level frame's origin and details instead of the requesting frame's. Apps that allow these permissions based on origin could grant an embedded frame access intended for the top-level page. You're only affected if you use setPermissionCheckHandler with origin-based logic for hid or usb and embed cross-origin iframes with allow="hid" or allow="usb". Apps that don't delegate those features to untrusted iframes are not affected. Workarounds Don't add allow="hid" / allow="usb" to untrusted iframes, or make the decision in your select-hid-device / select-usb-device handler using details.frame. Fixed Versions 45.0.0-alpha.5 44.3.0 43.7.0 42.11.3 For more information If you have any questions or comments about this advisory, email us at security@electronjs.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fw47-9c62-h3vw

  2. Revision 2 · amended ·

    Amended from osv record GHSA-fw47-9c62-h3vw

  3. Revision 1 · created ·

    Published from ghsa record GHSA-fw47-9c62-h3vw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113800

Advisory: Electron: HID and USB permission checks can be attributed to the wrong origin
IDs: CVE-2026-113800, GHSA-fw47-9c62-h3vw
Record: https://patchnext.com/advisories/cve-2026-113800 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: electron 45.0.0-alpha.5, 44.3.0, 43.7.0, 42.11.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm electron: affected >= 45.0.0-alpha.1, < 45.0.0-alpha.5; >= 44.0.0-alpha.1, < 44.3.0; >= 43.0.0-alpha.1, < 43.7.0; < 42.11.3; fixed in 44.3.0, 45.0.0-alpha.5, 42.11.3, 43.7.0

## Suggested inspection (read-only)
- `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on electron.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fw47-9c62-h3vw (GitHub-reviewed advisory GHSA-fw47-9c62-h3vw lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.3)
- Verified: https://osv.dev/vulnerability/GHSA-fw47-9c62-h3vw (OSV record GHSA-fw47-9c62-h3vw lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…