Electron: Pointer lock permission requests can be attributed to the wrong frame
CVE-2026-113798GHSA-x562-297c-g43g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (electron 45.0.0-alpha.13, 44.5.0, 43.7.6, 42.11.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm electron
- Affected
- >= 45.0.0-alpha.1, < 45.0.0-alpha.13>= 44.0.0-alpha.1, < 44.5.0>= 43.0.0-alpha.1, < 43.7.6< 42.11.9
- Fixed in
- 42.11.9, 43.7.6, 45.0.0-alpha.13, 44.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x562-297c-g43g lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x562-297c-g43g lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- EPSS
- CVE-2026-113798: 0.24% estimated exploitation activity in the next 30 days; percentile 15.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact For pointerLock permission requests made from some cross-origin iframes, session.setPermissionRequestHandler() was given the top-level frame's requestingUrl and isMainFrame instead of the requesting frame's. Apps that grant pointer lock based on the requesting origin could grant it to embedded content under the top-level page's identity. Apps are only affected if they embed untrusted content in iframes and decide pointerLock requests by origin in setPermissionRequestHandler. Apps that do not embed untrusted content, or that deny pointerLock for it, are not affected. Workarounds Deny the pointerLock permission for web contents that embed untrusted frames. Fixed Versions 45.0.0-alpha.13 44.5.0 43.7.6 42.11.9 For more information If you have any questions or comments about this advisory, email us at security@electronjs.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x562-297c-g43g
- Revision 2 · amended ·
Amended from osv record GHSA-x562-297c-g43g
- Revision 1 · created ·
Published from ghsa record GHSA-x562-297c-g43g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-113798 Advisory: Electron: Pointer lock permission requests can be attributed to the wrong frame IDs: CVE-2026-113798, GHSA-x562-297c-g43g Record: https://patchnext.com/advisories/cve-2026-113798 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: electron 45.0.0-alpha.13, 44.5.0, 43.7.6, 42.11.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm electron: affected >= 45.0.0-alpha.1, < 45.0.0-alpha.13; >= 44.0.0-alpha.1, < 44.5.0; >= 43.0.0-alpha.1, < 43.7.6; < 42.11.9; fixed in 42.11.9, 43.7.6, 45.0.0-alpha.13, 44.5.0 ## Suggested inspection (read-only) - `npm ls electron --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on electron. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x562-297c-g43g (GitHub-reviewed advisory GHSA-x562-297c-g43g lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.9) - Verified: https://osv.dev/vulnerability/GHSA-x562-297c-g43g (OSV record GHSA-x562-297c-g43g lists affected ranges: npm electron >=45.0.0-alpha.1 =44.0.0-alpha.1 =43.0.0-alpha.1 =0 <42.11.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…