Skip to content

← Actionable
High, CVSS 7.8amended

virtualenv activate.fish runs commands from a path or prompt with a backslash before a quote

CVE-2026-113732GHSA-c947-3pg5-gm8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.2; virtualenv 21.14.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI virtualenv

    Affected
    < 21.14.2
    Fixed in
    21.14.2
  • Bitnami virtualenv

    Affected
    < 21.14.2
    Fixed in
    21.14.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-113732: 0.24% estimated exploitation activity in the next 30 days; percentile 14.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact `FishActivator` defines no `quote()`, so it inherits `ViaTemplateActivator.quote`, which returns `shlex.quote(string)`. That function follows POSIX `sh` rules, where a backslash inside single quotes stays a literal character. fish reads `\'` inside single quotes as an escaped quote and `\\` as an escaped backslash. A value with a backslash before a quote therefore ends the literal somewhere other than where `shlex.quote` put the end, and fish expands the command substitution that follows. The environment path reaches `set -gx VIRTUAL_ENV`, and `--prompt` or `VIRTUALENV_PROMPT` reaches `set -gx VIRTUAL_ENV_PROMPT`. For `--prompt "x\'\$(touch PWNED)'\'"`, the generated `activate.fish` contains: ```fish set -gx VIRTUAL_ENV_PROMPT 'x\'"'"'$(touch PWNED)'"'"'\'"'"'' ``` `source bin/activate.fish` runs `touch PWNED`, and fish prints no error. The same payload as a directory name runs through `VIRTUAL_ENV`. `--prompt .` takes the current directory's name, so running virtualenv…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record BIT-virtualenv-2026-113732

  2. Revision 4 · amended ·

    Amended from osv record GHSA-c947-3pg5-gm8q

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-c947-3pg5-gm8q

  4. Revision 2 · amended ·

    Amended from osv record GHSA-c947-3pg5-gm8q

  5. Revision 1 · created ·

    Published from ghsa record GHSA-c947-3pg5-gm8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113732

Advisory: virtualenv activate.fish runs commands from a path or prompt with a backslash before a quote
IDs: CVE-2026-113732, GHSA-c947-3pg5-gm8q
Record: https://patchnext.com/advisories/cve-2026-113732 (revision 5, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.2; virtualenv 21.14.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected < 21.14.2; fixed in 21.14.2
- Bitnami virtualenv: affected < 21.14.2; fixed in 21.14.2

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.
- Bitnami virtualenv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c947-3pg5-gm8q (GitHub-reviewed advisory GHSA-c947-3pg5-gm8q lists affected ranges: PyPI virtualenv >=0 <=21.14.1)
- Verified: https://osv.dev/vulnerability/GHSA-c947-3pg5-gm8q (OSV record GHSA-c947-3pg5-gm8q lists affected ranges: PyPI virtualenv >=0 <21.14.2 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113732 (OSV record BIT-virtualenv-2026-113732 lists affected ranges: Bitnami virtualenv >=0 <21.14.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…