virtualenv activate runs commands from the environment name in zsh with PROMPT_SUBST
CVE-2026-113726GHSA-5vjq-rrrf-7h2q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.4; virtualenv 21.14.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI virtualenv
- Affected
- < 21.14.4
- Fixed in
- 21.14.4
Bitnami virtualenv
- Affected
- < 21.14.4
- Fixed in
- 21.14.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5vjq-rrrf-7h2q lists affected ranges: PyPI virtualenv >=0 <=21.14.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5vjq-rrrf-7h2q lists affected ranges: PyPI virtualenv >=0 <21.14.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-virtualenv-2026-113726 lists affected ranges: Bitnami virtualenv >=0 <21.14.4 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-113726: 0.34% estimated exploitation activity in the next 30 days; percentile 28.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact zsh users activate an environment with the bash `activate` script, which puts the environment name into `PS1`. Since 21.13.0 the script escapes backslashes, dollar signs and backticks in that name, but only when `BASH_VERSION` is set, so zsh gets the raw value. With the `PROMPT_SUBST` option set, zsh runs parameter expansion, command substitution and arithmetic expansion on `PS1` each time it draws the prompt. A name that contains `$(...)`, backticks or `${...}` then runs as commands in the user's shell, once per prompt. The name comes from the environment directory, or from `--prompt` or `VIRTUALENV_PROMPT`. After you create an environment with: ```console $ virtualenv 'x$(touch PWNED)y' ``` `source 'x$(touch PWNED)y/bin/activate'` in a zsh session with `PROMPT_SUBST` set creates `PWNED`, and the prompt shows `(xy)`. Passing that value as `--prompt` to an environment with a plain name has the same effect. Without `PROMPT_SUBST`, zsh shows the name as text and runs…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record BIT-virtualenv-2026-113726
- Revision 4 · amended ·
Amended from osv record GHSA-5vjq-rrrf-7h2q
- Revision 3 · amended ·
Amended from ghsa record GHSA-5vjq-rrrf-7h2q
- Revision 2 · amended ·
Amended from osv record GHSA-5vjq-rrrf-7h2q
- Revision 1 · created ·
Published from ghsa record GHSA-5vjq-rrrf-7h2q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-113726 Advisory: virtualenv activate runs commands from the environment name in zsh with PROMPT_SUBST IDs: CVE-2026-113726, GHSA-5vjq-rrrf-7h2q Record: https://patchnext.com/advisories/cve-2026-113726 (revision 5, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.4; virtualenv 21.14.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI virtualenv: affected < 21.14.4; fixed in 21.14.4 - Bitnami virtualenv: affected < 21.14.4; fixed in 21.14.4 ## Suggested inspection (read-only) - `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active. - Bitnami virtualenv: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on virtualenv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5vjq-rrrf-7h2q (GitHub-reviewed advisory GHSA-5vjq-rrrf-7h2q lists affected ranges: PyPI virtualenv >=0 <=21.14.3) - Verified: https://osv.dev/vulnerability/GHSA-5vjq-rrrf-7h2q (OSV record GHSA-5vjq-rrrf-7h2q lists affected ranges: PyPI virtualenv >=0 <21.14.4 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113726 (OSV record BIT-virtualenv-2026-113726 lists affected ranges: Bitnami virtualenv >=0 <21.14.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…