virtualenv bash activate runs commands from an environment name with a backslash before $
CVE-2026-113725GHSA-vxj4-q4g9-crj7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.7; virtualenv 21.14.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI virtualenv
- Affected
- < 21.14.7
- Fixed in
- 21.14.7
Bitnami virtualenv
- Affected
- < 21.14.7
- Fixed in
- 21.14.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxj4-q4g9-crj7 lists affected ranges: PyPI virtualenv >=0 <=21.14.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vxj4-q4g9-crj7 lists affected ranges: PyPI virtualenv >=0 <21.14.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-virtualenv-2026-113725 lists affected ranges: Bitnami virtualenv >=0 <21.14.7 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-113725: 0.26% estimated exploitation activity in the next 30 days; percentile 18.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The bash `activate` script escapes the environment name for only one of the two passes bash makes over `PS1`, so a backslash in the name undoes the escaping and a name containing `\$(...)` runs as commands in the user's shell each time bash draws the prompt.
Affected area `src/virtualenv/activation/bash/activate.sh`, the block that prepends the environment name to `PS1`.
Attacker-controlled input The environment name: the environment directory's name, or the `--prompt` or `VIRTUALENV_PROMPT` value. An attacker needs to influence it, for example through a CI job or wrapper tool that passes a branch, project or job name through, or a directory in a cloned repository or unpacked archive. `--prompt .` takes the current directory's name.
Details bash handles `PS1` in two passes each time it draws the prompt: it first decodes backslash prompt escapes, turning `\\` into `\` and `\$` into `$` (or `#` for root), and then runs parameter expansion, command substitution…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record BIT-virtualenv-2026-113725
- Revision 4 · amended ·
Amended from osv record GHSA-vxj4-q4g9-crj7
- Revision 3 · amended ·
Amended from ghsa record GHSA-vxj4-q4g9-crj7
- Revision 2 · amended ·
Amended from osv record GHSA-vxj4-q4g9-crj7
- Revision 1 · created ·
Published from ghsa record GHSA-vxj4-q4g9-crj7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-113725 Advisory: virtualenv bash activate runs commands from an environment name with a backslash before $ IDs: CVE-2026-113725, GHSA-vxj4-q4g9-crj7 Record: https://patchnext.com/advisories/cve-2026-113725 (revision 5, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.7; virtualenv 21.14.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI virtualenv: affected < 21.14.7; fixed in 21.14.7 - Bitnami virtualenv: affected < 21.14.7; fixed in 21.14.7 ## Suggested inspection (read-only) - `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active. - Bitnami virtualenv: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on virtualenv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vxj4-q4g9-crj7 (GitHub-reviewed advisory GHSA-vxj4-q4g9-crj7 lists affected ranges: PyPI virtualenv >=0 <=21.14.6) - Verified: https://osv.dev/vulnerability/GHSA-vxj4-q4g9-crj7 (OSV record GHSA-vxj4-q4g9-crj7 lists affected ranges: PyPI virtualenv >=0 <21.14.7 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113725 (OSV record BIT-virtualenv-2026-113725 lists affected ranges: Bitnami virtualenv >=0 <21.14.7 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…