Skip to content

← Actionable
High, CVSS 7.8amended

virtualenv: Generated POSIX console launchers interpret destination paths as shell syntax

CVE-2026-113722GHSA-c978-59m8-c77v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.9; virtualenv 21.14.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI virtualenv

    Affected
    < 21.14.9
    Fixed in
    21.14.9
  • Bitnami virtualenv

    Affected
    < 21.14.9
    Fixed in
    21.14.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-113722: 0.29% estimated exploitation activity in the next 30 days; percentile 21.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A destination path supplied to virtualenv can be interpreted as shell syntax by a generated POSIX console launcher. The app-data seeder and pip delegate launcher generation to distlib but supply the interpreter path in a form that does not preserve it as literal data in the shell wrapper.

Affected area POSIX console scripts generated by the app-data seeder or pip when the interpreter path requires a shell wrapper. Windows executable launchers are not affected by this path.

Attacker-controlled input An attacker must influence the environment destination passed to virtualenv, and the user must subsequently run a generated launcher. The attacker does not need to modify an installed executable or control the user's app-data cache.

Affected code The relevant 21.14.8 source is in ScriptMakerCustom.

Mechanism The app-data…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record BIT-virtualenv-2026-113722

  2. Revision 4 · amended ·

    Amended from osv record GHSA-c978-59m8-c77v

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-c978-59m8-c77v

  4. Revision 2 · amended ·

    Amended from osv record GHSA-c978-59m8-c77v

  5. Revision 1 · created ·

    Published from ghsa record GHSA-c978-59m8-c77v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113722

Advisory: virtualenv: Generated POSIX console launchers interpret destination paths as shell syntax
IDs: CVE-2026-113722, GHSA-c978-59m8-c77v
Record: https://patchnext.com/advisories/cve-2026-113722 (revision 5, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.9; virtualenv 21.14.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected < 21.14.9; fixed in 21.14.9
- Bitnami virtualenv: affected < 21.14.9; fixed in 21.14.9

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.
- Bitnami virtualenv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c978-59m8-c77v (GitHub-reviewed advisory GHSA-c978-59m8-c77v lists affected ranges: PyPI virtualenv >=0 <21.14.9)
- Verified: https://osv.dev/vulnerability/GHSA-c978-59m8-c77v (OSV record GHSA-c978-59m8-c77v lists affected ranges: PyPI virtualenv >=0 <21.14.9 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113722 (OSV record BIT-virtualenv-2026-113722 lists affected ranges: Bitnami virtualenv >=0 <21.14.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…