Skip to content

← Actionable
High, CVSS 7.1amended

virtualenv: Xonsh activation literals depend on the script decoding codec

CVE-2026-113718GHSA-394h-qwmc-48pf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.9; virtualenv 21.14.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI virtualenv

    Affected
    < 21.14.9
    Fixed in
    21.14.9
  • Bitnami virtualenv

    Affected
    < 21.14.9
    Fixed in
    21.14.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-113718: 0.24% estimated exploitation activity in the next 30 days; percentile 15.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Caller-supplied prompt text can become executable syntax in the xonsh activation script. An attacker must influence the value passed to virtualenv, and a user must subsequently activate the environment.

Affected area Xonsh reads a UTF-8 activation script using a legacy multibyte encoding such as GBK. Printable non-ASCII bytes can change how the reader recognizes an adjacent quote. The report concerns POSIX activation. It does not establish exposure through unrelated activators.

Attacker-controlled input The attacker controls prompt or destination data passed as a virtualenv argument. The user later sources the generated activation script.

Affected code The relevant 21.14.8 source is in xonsh quote(), UTF-8 template…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 7 · amended ·

    Amended from osv record BIT-virtualenv-2026-113718

  2. Revision 6 · amended ·

    Amended from osv record GHSA-394h-qwmc-48pf

  3. Revision 5 · amended ·

    Amended from ghsa record GHSA-394h-qwmc-48pf

  4. Revision 4 · amended ·

    Amended from ghsa record GHSA-394h-qwmc-48pf

  5. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  6. Revision 2 · amended ·

    Amended from osv record GHSA-394h-qwmc-48pf

  7. Revision 1 · created ·

    Published from ghsa record GHSA-394h-qwmc-48pf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113718

Advisory: virtualenv: Xonsh activation literals depend on the script decoding codec
IDs: CVE-2026-113718, GHSA-394h-qwmc-48pf
Record: https://patchnext.com/advisories/cve-2026-113718 (revision 7, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.9; virtualenv 21.14.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected < 21.14.9; fixed in 21.14.9
- Bitnami virtualenv: affected < 21.14.9; fixed in 21.14.9

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.
- Bitnami virtualenv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-394h-qwmc-48pf (GitHub-reviewed advisory GHSA-394h-qwmc-48pf lists affected ranges: PyPI virtualenv >=0 <21.14.9)
- Verified: https://osv.dev/vulnerability/GHSA-394h-qwmc-48pf (OSV record GHSA-394h-qwmc-48pf lists affected ranges: PyPI virtualenv >=0 <21.14.9 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113718 (OSV record BIT-virtualenv-2026-113718 lists affected ranges: Bitnami virtualenv >=0 <21.14.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…