Skip to content

← Actionable
Low, CVSS 2.3amended

virtualenv: Pip seeding with download omits wheel digest verification

CVE-2026-113717GHSA-cx28-75q4-x26q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.9; virtualenv 21.14.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI virtualenv

    Affected
    < 21.14.9
    Fixed in
    21.14.9
  • Bitnami virtualenv

    Affected
    < 21.14.9
    Fixed in
    21.14.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-113717: 0.29% estimated exploitation activity in the next 30 days; percentile 21.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The pip seeder acquires bundled wheels with download=False and lets pip access the index when --download is selected. Index candidates on that path do not pass through virtualenv's wheel digest verification. Anthropic's OSS Scanner reported this as `ANT-2026-74ALJBUF` in `virtualenv-20261015-005`, received on 15 October 2026.

Affected area Wheel selection by the pip seeder when downloads are enabled.

Attacker-controlled input The pip seeder and download option must be selected. The finding concerns the default-index digest-verification policy. Explicit custom-index settings already opt out of comparison against PyPI metadata; this patch retains that policy.

Affected code The relevant 21.14.8 source is in pip seeder.

Mechanism With `--seeder pip --download`, `PipInvoke.get_pip_install_cmd()` first calls `get_wheel(download=False)`, so…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 7 · amended ·

    Amended from osv record BIT-virtualenv-2026-113717

  2. Revision 6 · amended ·

    Amended from osv record GHSA-cx28-75q4-x26q

  3. Revision 5 · amended ·

    Amended from ghsa record GHSA-cx28-75q4-x26q

  4. Revision 4 · amended ·

    Amended from ghsa record GHSA-cx28-75q4-x26q

  5. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  6. Revision 2 · amended ·

    Amended from osv record GHSA-cx28-75q4-x26q

  7. Revision 1 · created ·

    Published from ghsa record GHSA-cx28-75q4-x26q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113717

Advisory: virtualenv: Pip seeding with download omits wheel digest verification
IDs: CVE-2026-113717, GHSA-cx28-75q4-x26q
Record: https://patchnext.com/advisories/cve-2026-113717 (revision 7, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.9; virtualenv 21.14.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI virtualenv: affected < 21.14.9; fixed in 21.14.9
- Bitnami virtualenv: affected < 21.14.9; fixed in 21.14.9

## Suggested inspection (read-only)
- `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active.
- Bitnami virtualenv: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on virtualenv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cx28-75q4-x26q (GitHub-reviewed advisory GHSA-cx28-75q4-x26q lists affected ranges: PyPI virtualenv >=0 <21.14.9)
- Verified: https://osv.dev/vulnerability/GHSA-cx28-75q4-x26q (OSV record GHSA-cx28-75q4-x26q lists affected ranges: PyPI virtualenv >=0 <21.14.9 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113717 (OSV record BIT-virtualenv-2026-113717 lists affected ranges: Bitnami virtualenv >=0 <21.14.9 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…