virtualenv: Builtin creation follows linked environment directories
CVE-2026-113716GHSA-cw65-gx24-rc82
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (virtualenv 21.14.9; virtualenv 21.14.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI virtualenv
- Affected
- < 21.14.9
- Fixed in
- 21.14.9
Bitnami virtualenv
- Affected
- < 21.14.9
- Fixed in
- 21.14.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cw65-gx24-rc82 lists affected ranges: PyPI virtualenv >=0 <21.14.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cw65-gx24-rc82 lists affected ranges: PyPI virtualenv >=0 <21.14.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-virtualenv-2026-113716 lists affected ranges: Bitnami virtualenv >=0 <21.14.9 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.5 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-113716: 0.14% estimated exploitation activity in the next 30 days; percentile 3.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The builtin creator accepts existing directory symlinks through ensure_dir() and writes environment files through those directories. This permits writes outside the requested destination. Anthropic's OSS Scanner reported this as `ANT-2026-MUFJEG11` in `virtualenv-20261015-005`, received on 15 October 2026.
Affected area Directory preparation before environment files are created.
Attacker-controlled input Another account must be able to prepare linked entries below the chosen destination before creation. The invoking user must have access to the linked destination. This does not require write access to the target itself under the other account.
Affected code The relevant 21.14.8 source is in builtin creator,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record BIT-virtualenv-2026-113716
- Revision 4 · amended ·
Amended from osv record GHSA-cw65-gx24-rc82
- Revision 3 · amended ·
Amended from ghsa record GHSA-cw65-gx24-rc82
- Revision 2 · amended ·
Amended from osv record GHSA-cw65-gx24-rc82
- Revision 1 · created ·
Published from ghsa record GHSA-cw65-gx24-rc82
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-113716 Advisory: virtualenv: Builtin creation follows linked environment directories IDs: CVE-2026-113716, GHSA-cw65-gx24-rc82 Record: https://patchnext.com/advisories/cve-2026-113716 (revision 5, source checked 30 Oct 2026, 07:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: virtualenv 21.14.9; virtualenv 21.14.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI virtualenv: affected < 21.14.9; fixed in 21.14.9 - Bitnami virtualenv: affected < 21.14.9; fixed in 21.14.9 ## Suggested inspection (read-only) - `python -m pip show virtualenv`: prints the installed version. Run with the environment that serves production active. - Bitnami virtualenv: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on virtualenv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cw65-gx24-rc82 (GitHub-reviewed advisory GHSA-cw65-gx24-rc82 lists affected ranges: PyPI virtualenv >=0 <21.14.9) - Verified: https://osv.dev/vulnerability/GHSA-cw65-gx24-rc82 (OSV record GHSA-cw65-gx24-rc82 lists affected ranges: PyPI virtualenv >=0 <21.14.9 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-virtualenv-2026-113716 (OSV record BIT-virtualenv-2026-113716 lists affected ranges: Bitnami virtualenv >=0 <21.14.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…