Skip to content

← Actionable
High, CVSS 7.5amended

ApostropheCMS: Unauthenticated resource exhaustion via pre-auth aposBigUpload processing in @apostrophecms/import-export

CVE-2026-113711GHSA-86wm-68pq-5jwq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/import-export 3.7.0; apostrophe 4.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-113711: 0.56% estimated exploitation activity in the next 30 days; percentile 46.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A potential unauthenticated denial-of-service vulnerability exists in the chunked import upload path used by @apostrophecms/import-export. The affected import API routes invoke: self.apos.http.bigUploadMiddleware() before the actual import handler performs its authentication check. Because no authorize callback is supplied to bigUploadMiddleware(), unauthenticated requests can reach the aposBigUpload start, chunk, and end operations before the later req.user check rejects the import. As a result, an unauthenticated remote attacker can create server-side upload state, write chunk data to upload storage, trigger temporary-file processing, and cause attacker-controlled cleanup operations before authentication is enforced. Affected Component Package: @apostrophecms/import-export Confirmed affected version: 3.6.2 Potential earlier affected versions: The issue may affect earlier 3.x releases in which the current big-upload-based import implementation is present. I have not yet…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-86wm-68pq-5jwq

  2. Revision 2 · amended ·

    Amended from osv record GHSA-86wm-68pq-5jwq

  3. Revision 1 · created ·

    Published from ghsa record GHSA-86wm-68pq-5jwq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113711

Advisory: ApostropheCMS: Unauthenticated resource exhaustion via pre-auth aposBigUpload processing in @apostrophecms/import-export
IDs: CVE-2026-113711, GHSA-86wm-68pq-5jwq
Record: https://patchnext.com/advisories/cve-2026-113711 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/import-export 3.7.0; apostrophe 4.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/import-export: affected < 3.7.0; fixed in 3.7.0
- npm apostrophe: affected < 4.33.0; fixed in 4.33.0

## Suggested inspection (read-only)
- `npm ls @apostrophecms/import-export --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/import-export, apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-86wm-68pq-5jwq (GitHub-reviewed advisory GHSA-86wm-68pq-5jwq lists affected ranges: npm apostrophe >=0 =0 <3.7.0)
- Verified: https://osv.dev/vulnerability/GHSA-86wm-68pq-5jwq (OSV record GHSA-86wm-68pq-5jwq lists affected ranges: npm apostrophe >=0 =0 <3.7.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…