ApostropheCMS: No Attempt Throttling on Authenticated Password-Change Endpoint Enables Unlimited Current-Password Guessing
CVE-2026-113710GHSA-653j-g8j7-gh54
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apostrophe
- Affected
- < 4.33.0
- Fixed in
- 4.33.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-653j-g8j7-gh54 lists affected ranges: npm apostrophe >=0 <4.33.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-653j-g8j7-gh54 lists affected ranges: npm apostrophe >=0 <4.33.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-113710: 0.33% estimated exploitation activity in the next 30 days; percentile 26.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The self-service password-change endpoint verifies the current password but does not use the login module’s failed-attempt counter, throttle, delay, or lockout mechanism. An attacker with a valid authenticated session can submit repeated guesses for the current password without receiving a lockout or throttle response. Exact source path packages/apostrophe/modules/@apostrophecms/settings/index.js:621-664 The password-change route is: PATCH /api/v1/@apostrophecms/settings/password The route calls the password verifier directly through: await self.handleProtectedSubform(req, subform, req.body ); The password verification path is: packages/apostrophe/modules/@apostrophecms/settings/index.js:514-542 async handlePasswordProtectedSubform(req, subform, payload) { try { await self.apos.user.verifyPassword(req.user, payload.passwordCurrent); } catch (e) { throw self.apos.error( 'forbidden', 'apostrophe:passwordCurrentError', { path: 'passwordCurrent' } ); } return subform; } The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-653j-g8j7-gh54
- Revision 2 · amended ·
Amended from osv record GHSA-653j-g8j7-gh54
- Revision 1 · created ·
Published from ghsa record GHSA-653j-g8j7-gh54
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-113710 Advisory: ApostropheCMS: No Attempt Throttling on Authenticated Password-Change Endpoint Enables Unlimited Current-Password Guessing IDs: CVE-2026-113710, GHSA-653j-g8j7-gh54 Record: https://patchnext.com/advisories/cve-2026-113710 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apostrophe: affected < 4.33.0; fixed in 4.33.0 ## Suggested inspection (read-only) - `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apostrophe. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-653j-g8j7-gh54 (GitHub-reviewed advisory GHSA-653j-g8j7-gh54 lists affected ranges: npm apostrophe >=0 <4.33.0) - Verified: https://osv.dev/vulnerability/GHSA-653j-g8j7-gh54 (OSV record GHSA-653j-g8j7-gh54 lists affected ranges: npm apostrophe >=0 <4.33.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…