Skip to content

← Actionable
Medium, CVSS 4.3amended

ApostropheCMS: Host header controls server-side image fetch origin in @apostrophecms/ai-helper, enabling authenticated SSRF

CVE-2026-113671GHSA-527g-ff96-x6wj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/ai-helper 1.0.0-beta.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-113671: 0.33% estimated exploitation activity in the next 30 days; percentile 26.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The @apostrophecms/ai-helper package builds the URL for a server-side image fetch by resolving a storage-relative path against req.baseUrl. When the site does not set a global base URL (the default), req.baseUrl is derived from the incoming HTTP Host header. An authenticated editor can generate a base64 AI image (which is persisted without a stored url) and then send an unauthorized PATCH accept request with an attacker-chosen Host header. The server then issues an outbound GET to the attacker-selected origin, producing a Server-Side Request Forgery primitive that reaches hosts and ports the client cannot otherwise contact. The affected code lives in packages/ai-helper/modules/@apostrophecms/ai-helper-image/index.js. Root Cause The image accept route trusts req.baseUrl as a safe origin for constructing an internal fetch target, but req.baseUrl is attacker-influenced whenever the site has no configured base URL. The URL builder concatenates a default local storage path (which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-527g-ff96-x6wj

  2. Revision 2 · amended ·

    Amended from osv record GHSA-527g-ff96-x6wj

  3. Revision 1 · created ·

    Published from ghsa record GHSA-527g-ff96-x6wj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113671

Advisory: ApostropheCMS: Host header controls server-side image fetch origin in @apostrophecms/ai-helper, enabling authenticated SSRF
IDs: CVE-2026-113671, GHSA-527g-ff96-x6wj
Record: https://patchnext.com/advisories/cve-2026-113671 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/ai-helper 1.0.0-beta.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/ai-helper: affected >= 1.0.0-beta.10, < 1.0.0-beta.13; fixed in 1.0.0-beta.13

## Suggested inspection (read-only)
- `npm ls @apostrophecms/ai-helper --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/ai-helper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-527g-ff96-x6wj (GitHub-reviewed advisory GHSA-527g-ff96-x6wj lists affected ranges: npm @apostrophecms/ai-helper >=1.0.0-beta.10 <1.0.0-beta.13)
- Verified: https://osv.dev/vulnerability/GHSA-527g-ff96-x6wj (OSV record GHSA-527g-ff96-x6wj lists affected ranges: npm @apostrophecms/ai-helper >=1.0.0-beta.10 <1.0.0-beta.13 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…