Skip to content

← Actionable
Medium, CVSS 5.3amended

ApostropheCMS: Cross-domain session token in URL confers session takeover

CVE-2026-113669GHSA-hhvr-8m24-qqr3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/passport-bridge 1.6.1; apostrophe 4.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-113669: 0.42% estimated exploitation activity in the next 30 days; percentile 35.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Apostrophe's cross-domain session migration emits a single-use session token as a URL query parameter and stores it in the Mongo cache. Any client that presents the token silently adopts the target user's full session (including passport.user) with no credentials. Details packages/apostrophe/modules/@apostrophecms/i18n/index.js: - Token generation on cross-host/locale flows (L479–487) and passport-bridge cross-locale redirect (passport-bridge/index.js L557–593) places the token in the URL. - acceptCrossDomainSessionToken (L258–298) reads ?aposCrossDomainSessionToken, Object.assigns the stored session (cookie + passport.user) onto req.session, then nulls the cache entry under namespace @apostrophecms/i18n:cross-domain-sessions. - Middleware without before: is registered for every URL (express findModuleMiddlewareAndRoutes L820–879); verified with APOSLOGALLROUTES=1. PoC Impact Session hijack / account takeover of the migrated user for anyone who obtains the token, inheriting…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-hhvr-8m24-qqr3

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-hhvr-8m24-qqr3

  4. Revision 1 · created ·

    Published from ghsa record GHSA-hhvr-8m24-qqr3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113669

Advisory: ApostropheCMS: Cross-domain session token in URL confers session takeover
IDs: CVE-2026-113669, GHSA-hhvr-8m24-qqr3
Record: https://patchnext.com/advisories/cve-2026-113669 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/passport-bridge 1.6.1; apostrophe 4.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/passport-bridge: affected < 1.6.1; fixed in 1.6.1
- npm apostrophe: affected < 4.33.0; fixed in 4.33.0

## Suggested inspection (read-only)
- `npm ls @apostrophecms/passport-bridge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/passport-bridge, apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hhvr-8m24-qqr3 (GitHub-reviewed advisory GHSA-hhvr-8m24-qqr3 lists affected ranges: npm apostrophe >=0 =0 <1.6.1)
- Verified: https://osv.dev/vulnerability/GHSA-hhvr-8m24-qqr3 (OSV record GHSA-hhvr-8m24-qqr3 lists affected ranges: npm apostrophe >=0 =0 <1.6.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…