Skip to content

← Actionable
High, CVSS 7.1amended

ApostropheCMS: Authenticated projection-exclusion prototype-member deletion in @apostrophecms/db-connect causes process-wide denial of service

CVE-2026-113666GHSA-j5rq-xfvr-p969

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/db-connect 1.1.0; apostrophe 4.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2026-113666: 0.44% estimated exploitation activity in the next 30 days; percentile 38.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @apostrophecms/db-connect ships an in-memory MongoDB emulation used by its SQLite, PostgreSQL, and multipostgres adapters. Its unsetNestedField helper walks an attacker-controlled dotted field path with no segment validation and calls delete on the resolved property. A low-privileged authenticated user (any role holding view-draft, which every editor and contributor has; reduced to any logged-in user when guestApiAccess is enabled) can send a piece-type REST GET request whose project query builder contains an exclusion key such as constructor.prototype.hasOwnProperty. On a SQLite or PostgreSQL adapter this key reaches unsetNestedField, which resolves Object.prototype and deletes a shared runtime method. Because that method is shared across the whole Node process, the deletion breaks request handling for every tenant and user until the process is restarted, giving a single request a persistent denial of service. Root Cause The projection query builder laundens only projection…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-j5rq-xfvr-p969

  2. Revision 2 · amended ·

    Amended from osv record GHSA-j5rq-xfvr-p969

  3. Revision 1 · created ·

    Published from ghsa record GHSA-j5rq-xfvr-p969

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113666

Advisory: ApostropheCMS: Authenticated projection-exclusion prototype-member deletion in @apostrophecms/db-connect causes process-wide denial of service
IDs: CVE-2026-113666, GHSA-j5rq-xfvr-p969
Record: https://patchnext.com/advisories/cve-2026-113666 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/db-connect 1.1.0; apostrophe 4.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/db-connect: affected < 1.1.0; fixed in 1.1.0
- npm apostrophe: affected < 4.33.0; fixed in 4.33.0

## Suggested inspection (read-only)
- `npm ls @apostrophecms/db-connect --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/db-connect, apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j5rq-xfvr-p969 (GitHub-reviewed advisory GHSA-j5rq-xfvr-p969 lists affected ranges: npm @apostrophecms/db-connect >=0 =0 <4.33.0)
- Verified: https://osv.dev/vulnerability/GHSA-j5rq-xfvr-p969 (OSV record GHSA-j5rq-xfvr-p969 lists affected ranges: npm @apostrophecms/db-connect >=0 =0 <4.33.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…