ApostropheCMS: Missing Authorization on Notification PATCH/DELETE Endpoints
CVE-2026-113665GHSA-vwwx-px9w-crrc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.33.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apostrophe
- Affected
- < 4.33.0
- Fixed in
- 4.33.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vwwx-px9w-crrc lists affected ranges: npm apostrophe >=0 <4.33.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vwwx-px9w-crrc lists affected ranges: npm apostrophe >=0 <4.33.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-113665: 0.35% estimated exploitation activity in the next 30 days; percentile 28.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The notification module exposes PATCH and DELETE REST endpoints that perform operations directly on the underlying MongoDB collection without verifying that the requester is authenticated or owns the target notification. As a result, an unauthenticated attacker who obtains a valid notification ID can modify or permanently delete another user's notification. --- Affected Code File Unlike the GET notification route, these handlers do not verify: - Authentication (req.user) - Ownership (userId === req.user.id) - Authorization or permissions Instead, the supplied id is used directly against the raw MongoDB collection. --- Root Cause The notification REST endpoints perform database operations directly using self.db without enforcing authentication or authorization. While the framework provides permission primitives (req.user, ownership checks, and apos.permission), these endpoints never invoke them. As a result, any request reaching these handlers is processed solely based on the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vwwx-px9w-crrc
- Revision 2 · amended ·
Amended from osv record GHSA-vwwx-px9w-crrc
- Revision 1 · created ·
Published from ghsa record GHSA-vwwx-px9w-crrc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-113665 Advisory: ApostropheCMS: Missing Authorization on Notification PATCH/DELETE Endpoints IDs: CVE-2026-113665, GHSA-vwwx-px9w-crrc Record: https://patchnext.com/advisories/cve-2026-113665 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.33.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apostrophe: affected < 4.33.0; fixed in 4.33.0 ## Suggested inspection (read-only) - `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apostrophe. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vwwx-px9w-crrc (GitHub-reviewed advisory GHSA-vwwx-px9w-crrc lists affected ranges: npm apostrophe >=0 <4.33.0) - Verified: https://osv.dev/vulnerability/GHSA-vwwx-px9w-crrc (OSV record GHSA-vwwx-px9w-crrc lists affected ranges: npm apostrophe >=0 <4.33.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…