Skip to content

← Actionable
Medium, CVSS 5.3amended

ApostropheCMS import-export tar guard misses './..' because it is a literal '../' substring test

CVE-2026-113664GHSA-97wv-p4xx-c7mg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/import-export 3.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-113664: 0.48% estimated exploitation activity in the next 30 days; percentile 41.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The tar-extraction guard added to @apostrophecms/import-export for GHSA-mwxc-m426-3f78 is a literal substring test for ../, and ./.. does not contain that substring. An entry named ./.. therefore passes the guard, path.join normalizes it to the parent of the export directory, and the resulting fs.WriteStream opens a directory and emits EISDIR with no error listener attached, which terminates the Node process. Confirmed on default-branch HEAD 1bd5d0a7a6fe880836fa75adad6964f1c577d640, package version 3.6.2. Details packages/import-export/lib/formats/gzip.js, in the tar-stream entry handler inside extract(filepath, exportPath): Two separate problems sit in those four lines. The guard tests the raw entry name for a substring instead of resolving the joined path and requiring containment, and the write stream has no error handler, so any stream error becomes an unhandled 'error' event. Reaching it needs an account that can import, nothing more.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-97wv-p4xx-c7mg

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-97wv-p4xx-c7mg

  4. Revision 1 · created ·

    Published from ghsa record GHSA-97wv-p4xx-c7mg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113664

Advisory: ApostropheCMS import-export tar guard misses './..' because it is a literal '../' substring test
IDs: CVE-2026-113664, GHSA-97wv-p4xx-c7mg
Record: https://patchnext.com/advisories/cve-2026-113664 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/import-export 3.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/import-export: affected < 3.7.0; fixed in 3.7.0

## Suggested inspection (read-only)
- `npm ls @apostrophecms/import-export --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/import-export.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-97wv-p4xx-c7mg (GitHub-reviewed advisory GHSA-97wv-p4xx-c7mg lists affected ranges: npm @apostrophecms/import-export >=0 <3.7.0)
- Verified: https://osv.dev/vulnerability/GHSA-97wv-p4xx-c7mg (OSV record GHSA-97wv-p4xx-c7mg lists affected ranges: npm @apostrophecms/import-export >=0 <3.7.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…