Skip to content

← Actionable
High, CVSS 7.5amended

ApostropheCMS: Unauthenticated CSV import requests leave rejected uploads in the system temporary directory

CVE-2026-113658GHSA-qhcq-9pm2-c9w9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.33.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-113658: 0.61% estimated exploitation activity in the next 30 days; percentile 49.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A rejected upload can remain in the operating system temporary directory. Multer writes the file before its extension is checked, and the rejection path does not remove that temporary file. An unauthenticated requester can repeat this with large files and steadily consume temporary disk space. Details The endpoint is: In packages/apostrophe/modules/@apostrophecms/rich-text-widget/lib/apiRoutes.js, Multer first writes the upload to os.tmpdir(). The handler then rejects filenames whose extension is not csv, but there is no cleanup of the Multer file on this error path. The route does not require an authenticated user. A normal CSRF cookie is sufficient. During testing, the request returned HTTP 400 with Only csv files are supported, while the complete uploaded content remained in a randomly named file in the configured temporary directory after the response. Relationship to prior public work I reviewed PR #5013, which migrated the Rich Text CSV upload path from…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qhcq-9pm2-c9w9

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qhcq-9pm2-c9w9

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qhcq-9pm2-c9w9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113658

Advisory: ApostropheCMS: Unauthenticated CSV import requests leave rejected uploads in the system temporary directory
IDs: CVE-2026-113658, GHSA-qhcq-9pm2-c9w9
Record: https://patchnext.com/advisories/cve-2026-113658 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.33.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apostrophe: affected < 4.33.0; fixed in 4.33.0

## Suggested inspection (read-only)
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qhcq-9pm2-c9w9 (GitHub-reviewed advisory GHSA-qhcq-9pm2-c9w9 lists affected ranges: npm apostrophe >=0 <4.33.0)
- Verified: https://osv.dev/vulnerability/GHSA-qhcq-9pm2-c9w9 (OSV record GHSA-qhcq-9pm2-c9w9 lists affected ranges: npm apostrophe >=0 <4.33.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…