Skip to content

← Actionable
Medium, CVSS 5.3amended

ApostropheCMS sanitize-html: unbounded recursion when re-sanitizing the fallback of a discarded iframe (stack overflow, nestingLimit not enforced)

CVE-2026-113650GHSA-c9rx-x947-fp3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sanitize-html 2.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-113650: 0.48% estimated exploitation activity in the next 30 days; percentile 41.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Since 2.18.0, when an <iframe is not allowed and disallowedTagsMode is 'discard' (the defaults), its raw-text content is re-sanitized by a recursive call to sanitizeHtml(text, options) (the change from #5564, fixing #5550). The recursion has no bound and starts each nested call with a fresh state. Two consequences, both absent from 2.17.7 and 2.17.4: 1. A few kilobytes of unclosed <iframe tags throw RangeError: Maximum call stack size exceeded with the default options. Any application that sanitizes untrusted HTML with 2.18.0 can be made to throw on a small crafted input. 2. nestingLimit is not enforced across a discarded iframe: each nested iframe restarts the depth count at zero, so the output can be nested arbitrarily deep regardless of the configured limit. Affected versions - 2.18.0 (the current latest), and the main branch at the time of writing (the recursive call is still in packages/sanitize-html/index.js, in the ontext handler, branch tag === 'iframe' &&…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c9rx-x947-fp3h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-c9rx-x947-fp3h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-c9rx-x947-fp3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-113650

Advisory: ApostropheCMS sanitize-html: unbounded recursion when re-sanitizing the fallback of a discarded iframe (stack overflow, nestingLimit not enforced)
IDs: CVE-2026-113650, GHSA-c9rx-x947-fp3h
Record: https://patchnext.com/advisories/cve-2026-113650 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sanitize-html 2.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sanitize-html: affected >= 2.18.0, < 2.18.1; fixed in 2.18.1

## Suggested inspection (read-only)
- `npm ls sanitize-html --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sanitize-html.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c9rx-x947-fp3h (GitHub-reviewed advisory GHSA-c9rx-x947-fp3h lists affected ranges: npm sanitize-html >=2.18.0 <2.18.1)
- Verified: https://osv.dev/vulnerability/GHSA-c9rx-x947-fp3h (OSV record GHSA-c9rx-x947-fp3h lists affected ranges: npm sanitize-html >=2.18.0 <2.18.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…