Skip to content

← Actionable
Medium, CVSS 6.5amended

ApostropheCMS: Archive duplicate continuation lets contributors overwrite published content

CVE-2026-112956GHSA-jf5h-36mg-rp6x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/import-export 3.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-112956: 0.34% estimated exploitation activity in the next 30 days; percentile 27.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Review scope and evidence limits Package: @apostrophecms/import-export, version 3.7.0. Release tag reviewed: @apostrophecms/import-export@3.7.0, commit 9500b8b0e1d630d5e07fbb5fd2c25ed0943845ce (September 30, 2026). Current main reviewed: 5ce3732be0ebdebb4db0f8ef160c81e8671157e6. The importer, gzip extractor, import permission gate, and core permission implementation have no differences between that release tag and the reviewed main. This follow-up is a static remediation review. We have not repeated the original end-to-end reproductions against the latest release or tested a deployed site. Current exploitability and impact therefore still require maintainer validation; the observations below establish that the reported security checks remain absent in public source. The original emailed PDF contains the original reproduction material. Please refer to that existing private attachment. Archive duplicate continuation permits unauthorized published-content replacement The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jf5h-36mg-rp6x

  2. Revision 2 · amended ·

    Amended from osv record GHSA-jf5h-36mg-rp6x

  3. Revision 1 · created ·

    Published from ghsa record GHSA-jf5h-36mg-rp6x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112956

Advisory: ApostropheCMS: Archive duplicate continuation lets contributors overwrite published content
IDs: CVE-2026-112956, GHSA-jf5h-36mg-rp6x
Record: https://patchnext.com/advisories/cve-2026-112956 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/import-export 3.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/import-export: affected < 3.7.1; fixed in 3.7.1

## Suggested inspection (read-only)
- `npm ls @apostrophecms/import-export --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/import-export.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jf5h-36mg-rp6x (GitHub-reviewed advisory GHSA-jf5h-36mg-rp6x lists affected ranges: npm @apostrophecms/import-export >=0 <3.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-jf5h-36mg-rp6x (OSV record GHSA-jf5h-36mg-rp6x lists affected ranges: npm @apostrophecms/import-export >=0 <3.7.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…