Skip to content

← Actionable
Medium, CVSS 5.3amended

ApostropheCMS: Unauthenticated publicApiProjection bypass via search and sort query builders in the public REST API

CVE-2026-112954GHSA-rqgm-cfrp-4hx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.34.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-112954: 0.44% estimated exploitation activity in the next 30 days; percentile 38.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary ApostropheCMS lets a module expose an anonymous read API by setting publicApiProjection, which whitelists the document fields unauthenticated callers may see. The public REST GET handler applies every launderable query builder from the query string before forcing that projection. Two of those builders, search and sort, operate on the underlying documents rather than the projected output, and neither is checked against the projection. An unauthenticated attacker can therefore: - use ?search=<word as a value oracle to confirm and locate documents by the content of a field the projection was meant to hide, and - use ?sort[hiddenField]=1 as an ordering oracle to rank documents by a hidden field's value. This is the same confidentiality-bypass class already patched for the choices/counts builders (gated by choicesFieldAllowedByProjection). That gate was never applied to search or sort. Details For an anonymous caller, getRestQuery (piece types:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-rqgm-cfrp-4hx8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-rqgm-cfrp-4hx8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-rqgm-cfrp-4hx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112954

Advisory: ApostropheCMS: Unauthenticated publicApiProjection bypass via search and sort query builders in the public REST API
IDs: CVE-2026-112954, GHSA-rqgm-cfrp-4hx8
Record: https://patchnext.com/advisories/cve-2026-112954 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.34.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apostrophe: affected < 4.34.0; fixed in 4.34.0

## Suggested inspection (read-only)
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rqgm-cfrp-4hx8 (GitHub-reviewed advisory GHSA-rqgm-cfrp-4hx8 lists affected ranges: npm apostrophe >=0 <4.34.0)
- Verified: https://osv.dev/vulnerability/GHSA-rqgm-cfrp-4hx8 (OSV record GHSA-rqgm-cfrp-4hx8 lists affected ranges: npm apostrophe >=0 <4.34.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…