Skip to content

← Actionable
Medium, CVSS 6.0amended

ApostropheCMS: Exposure of Sensitive Information via predictable export filenames

CVE-2026-112953GHSA-5gc8-frw3-3vqm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apostrophecms/import-export 3.7.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-112953: 0.56% estimated exploitation activity in the next 30 days; percentile 46.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When a user exports content through @apostrophecms/import-export, the module copies the generated archive into uploadfs at /exports/ and returns a public URL under /uploads/exports/. The filename is fully deterministic: site shortName, document type, a YYYYMMDDHHmmss timestamp, and the format extension. There is no secret token. Anyone who can guess that path can download the archive with a normal unauthenticated HTTP GET while the file is still present (10 minutes by default, longer if the site raises importExport.export.expiration). That is a different model from attachment URLs, which rely on hard-to-guess IDs. Sites that disable export, store uploads on a private backend with no anonymous read, or serve /uploads only behind authentication are not hit by the network download step—but the predictable naming is still a design flaw for the default local/public uploadfs layout. Import-only workflows and imports themselves are out of scope; this is specific to the export…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-5gc8-frw3-3vqm

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-5gc8-frw3-3vqm

  4. Revision 1 · created ·

    Published from ghsa record GHSA-5gc8-frw3-3vqm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112953

Advisory: ApostropheCMS: Exposure of Sensitive Information via predictable export filenames
IDs: CVE-2026-112953, GHSA-5gc8-frw3-3vqm
Record: https://patchnext.com/advisories/cve-2026-112953 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @apostrophecms/import-export 3.7.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @apostrophecms/import-export: affected < 3.7.1; fixed in 3.7.1

## Suggested inspection (read-only)
- `npm ls @apostrophecms/import-export --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @apostrophecms/import-export.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5gc8-frw3-3vqm (GitHub-reviewed advisory GHSA-5gc8-frw3-3vqm lists affected ranges: npm @apostrophecms/import-export >=0 <3.7.1)
- Verified: https://osv.dev/vulnerability/GHSA-5gc8-frw3-3vqm (OSV record GHSA-5gc8-frw3-3vqm lists affected ranges: npm @apostrophecms/import-export >=0 <3.7.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…