Skip to content

← Actionable
Medium, CVSS 4.3amended

ApostropheCMS: POST /api/v1/@apostrophecms/doc/slugTaken discloses existence of private/admin-only content to any authenticated user

CVE-2026-112952GHSA-f66c-mpj2-3r8h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.34.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-112952: 0.33% estimated exploitation activity in the next 30 days; percentile 26.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The slugTaken endpoint returns a boolean indicating whether a slug is in use across all document types and visibility levels, with no permission or type filter. Any logged-in user (including editors) can enumerate the slug space of private pages, drafts, and archived content. Details POST /api/v1/@apostrophecms/doc/slugTaken with body { "slug": "target-slug" } runs a raw existence check against the documents collection. It does not: - Check whether the requesting user has read permission for documents of that type. - Filter by visibility (public, loginRequired, private). - Filter by viewRole. - Filter by publication status (draft vs published). A single authenticated session can iterate the slug space to enumerate the full content inventory of the CMS, including content the user is explicitly prohibited from viewing. PoC Impact Information disclosure. An attacker with any authenticated session can enumerate all slugs in the system, mapping the full content structure of the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-f66c-mpj2-3r8h

  2. Revision 2 · amended ·

    Amended from osv record GHSA-f66c-mpj2-3r8h

  3. Revision 1 · created ·

    Published from ghsa record GHSA-f66c-mpj2-3r8h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112952

Advisory: ApostropheCMS: POST /api/v1/@apostrophecms/doc/slugTaken discloses existence of private/admin-only content to any authenticated user
IDs: CVE-2026-112952, GHSA-f66c-mpj2-3r8h
Record: https://patchnext.com/advisories/cve-2026-112952 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.34.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apostrophe: affected < 4.34.0; fixed in 4.34.0

## Suggested inspection (read-only)
- `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apostrophe.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f66c-mpj2-3r8h (GitHub-reviewed advisory GHSA-f66c-mpj2-3r8h lists affected ranges: npm apostrophe >=0 <4.34.0)
- Verified: https://osv.dev/vulnerability/GHSA-f66c-mpj2-3r8h (OSV record GHSA-f66c-mpj2-3r8h lists affected ranges: npm apostrophe >=0 <4.34.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…