ApostropheCMS: Color field validation bypass allows stored XSS via HTML appended after rgb()/hsl() prefix
CVE-2026-112951GHSA-vmgj-9cwm-cf3h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apostrophe 4.34.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm apostrophe
- Affected
- < 4.34.0
- Fixed in
- 4.34.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vmgj-9cwm-cf3h lists affected ranges: npm apostrophe >=0 <4.34.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vmgj-9cwm-cf3h lists affected ranges: npm apostrophe >=0 <4.34.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-112951: 0.30% estimated exploitation activity in the next 30 days; percentile 23.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The color field accepts any string that begins with a valid rgb() / hsl() color, because TinyColor.isValid does not anchor its match at the end of the string. An authenticated user with edit rights can store arbitrary HTML after a valid color prefix. When the stored value is rendered , the payload executes, resulting in stored XSS. Details Server-side validation of the color field relies on TinyColor: TinyColor's rgb/hsl matchers are not anchored at the end of the string, while hex matchers are. Tested with @ctrl/tinycolor | Input | isValid | |---|---| | rgb(1,2,3)<img src=x onerror=alert(1) | true | | rgb(1,2,3)</textarea<scriptalert(1)</script | true | | hsl(0,100%,50%);--x:1}</style<scriptalert(1)</script | true | | #ff0000<img src=x onerror=alert(1) | false | The value is saved to MongoDB unchanged (not normalized to hex8). Relation to GHSA-97v6-998m-fp4g GHSA-97v6 addressed CSS custom property injection escaping a <style context. The root cause (validation that accepts…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vmgj-9cwm-cf3h
- Revision 2 · amended ·
Amended from osv record GHSA-vmgj-9cwm-cf3h
- Revision 1 · created ·
Published from ghsa record GHSA-vmgj-9cwm-cf3h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112951 Advisory: ApostropheCMS: Color field validation bypass allows stored XSS via HTML appended after rgb()/hsl() prefix IDs: CVE-2026-112951, GHSA-vmgj-9cwm-cf3h Record: https://patchnext.com/advisories/cve-2026-112951 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apostrophe 4.34.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm apostrophe: affected < 4.34.0; fixed in 4.34.0 ## Suggested inspection (read-only) - `npm ls apostrophe --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apostrophe. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vmgj-9cwm-cf3h (GitHub-reviewed advisory GHSA-vmgj-9cwm-cf3h lists affected ranges: npm apostrophe >=0 <4.34.0) - Verified: https://osv.dev/vulnerability/GHSA-vmgj-9cwm-cf3h (OSV record GHSA-vmgj-9cwm-cf3h lists affected ranges: npm apostrophe >=0 <4.34.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…