Skip to content

← Actionable
Medium, CVSS 4.7amended

Vitest: Code injection via unauthenticated manual mock registration

CVE-2026-112949GHSA-qxg6-89mg-rqv8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vitest/mocker 5.0.3, 4.1.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @vitest/mocker

    Affected
    >= 2.1.0-beta.7, < 4.1.12>= 5.0.0-beta.1, < 5.0.3
    Fixed in
    4.1.12, 5.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-112949: 0.34% estimated exploitation activity in the next 30 days; percentile 27.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary @vitest/mocker's interceptorPlugin accepts mock registrations on Vite's dev-server WebSocket with no authentication, and interpolates the mock's url into generated module source without escaping. A client that can reach the dev server can make it serve arbitrary JavaScript in place of any project module, which then runs in the developer's browser on the dev-server origin. Same handler and same unauthenticated caller as GHSA-82fw-gwwq-j7x9; that fix (8ff9b9a9efca7c6cfd5243569440de8d7a33aec4, PR #10972) hardened only the redirect branch and left the manual branch reaching the unescaped generator. Patches Fixed in @vitest/mocker 5.0.3, released on 2026-09-30 (PR #11377), and backported to 4.1.12. createManualModuleSource now serializes the module URL and the export names with JSON.stringify, so a registered mock cannot change the generated code. Projects that call mockerPlugin() or interceptorPlugin() directly need @vitest/mocker 4.1.12 or 5.0.3. Details…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qxg6-89mg-rqv8

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qxg6-89mg-rqv8

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qxg6-89mg-rqv8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112949

Advisory: Vitest: Code injection via unauthenticated manual mock registration
IDs: CVE-2026-112949, GHSA-qxg6-89mg-rqv8
Record: https://patchnext.com/advisories/cve-2026-112949 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vitest/mocker 5.0.3, 4.1.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vitest/mocker: affected >= 2.1.0-beta.7, < 4.1.12; >= 5.0.0-beta.1, < 5.0.3; fixed in 4.1.12, 5.0.3

## Suggested inspection (read-only)
- `npm ls @vitest/mocker --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vitest/mocker.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxg6-89mg-rqv8 (GitHub-reviewed advisory GHSA-qxg6-89mg-rqv8 lists affected ranges: npm @vitest/mocker >=2.1.0-beta.7 =5.0.0-beta.1 <5.0.3)
- Verified: https://osv.dev/vulnerability/GHSA-qxg6-89mg-rqv8 (OSV record GHSA-qxg6-89mg-rqv8 lists affected ranges: npm @vitest/mocker >=2.1.0-beta.7 =5.0.0-beta.1 <5.0.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…