Skip to content

← Actionable
Medium, CVSS 6.5amended

Vitest: Servers misapply server.fs.deny, serving .env, private keys, .git, and the API token file

CVE-2026-112948GHSA-p458-7748-mcp3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vitest/ui 5.0.5; @vitest/browser 5.0.5; vite-plus 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @vitest/ui

    Affected
    >= 5.0.0-beta.6, < 5.0.5
    Fixed in
    5.0.5
  • npm @vitest/browser

    Affected
    >= 5.0.0-beta.6, < 5.0.5
    Fixed in
    5.0.5
  • npm vite-plus

    Affected
    >= 1.0.0-rc.0, < 1.3.0
    Fixed in
    1.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-112948: 0.40% estimated exploitation activity in the next 30 days; percentile 34.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In Vitest 5, Vite's server.fs.deny is not applied as intended on Vitest's dev servers. Depending on the server, files that Vite refuses to serve by default (such as .env, private keys and certificates, .npmrc, and .git) or Vitest's own API token file (.vitest-secret-token) can be read over plain HTTP by a client that can reach the server. In Browser Mode with test.projects, a malicious website can also read .env values through the developer's browser. This only applies when Vitest runs an HTTP server, which happens with the UI (--ui), Browser Mode, or api enabled. Plain vitest and vitest run don't listen on any port and are not affected. The fix ships in vitest, and @vitest/ui and @vitest/browser are listed because they are what enables the affected setups. Both pin vitest to the same version as a peer dependency, so upgrading either one also requires the patched vitest. Users who enable api without @vitest/ui or @vitest/browser are also affected and should upgrade vitest.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-p458-7748-mcp3

  2. Revision 2 · amended ·

    Amended from osv record GHSA-p458-7748-mcp3

  3. Revision 1 · created ·

    Published from ghsa record GHSA-p458-7748-mcp3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112948

Advisory: Vitest: Servers misapply `server.fs.deny`, serving `.env`, private keys, `.git`, and the API token file
IDs: CVE-2026-112948, GHSA-p458-7748-mcp3
Record: https://patchnext.com/advisories/cve-2026-112948 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vitest/ui 5.0.5; @vitest/browser 5.0.5; vite-plus 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vitest/ui: affected >= 5.0.0-beta.6, < 5.0.5; fixed in 5.0.5
- npm @vitest/browser: affected >= 5.0.0-beta.6, < 5.0.5; fixed in 5.0.5
- npm vite-plus: affected >= 1.0.0-rc.0, < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- `npm ls @vitest/ui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @vitest/browser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vite-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vitest/ui, @vitest/browser, vite-plus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p458-7748-mcp3 (GitHub-reviewed advisory GHSA-p458-7748-mcp3 lists affected ranges: npm @vitest/ui >=5.0.0-beta.6 =5.0.0-beta.6 =1.0.0-rc.0 <1.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-p458-7748-mcp3 (OSV record GHSA-p458-7748-mcp3 lists affected ranges: npm @vitest/ui >=5.0.0-beta.6 =5.0.0-beta.6 =1.0.0-rc.0 <1.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…