Vite: First 4 bytes of files outside of server.fs setting is exposed by ?vite-wasm-instance
CVE-2026-112947GHSA-vfpm-58rq-9qcg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 8.3.3, 8.2.4; vite-plus 1.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfpm-58rq-9qcg lists affected ranges: npm vite >=8.3.0 =8.2.0 =0.2.8 <=1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vfpm-58rq-9qcg lists affected ranges: npm vite >=8.3.0 =8.2.0 =0.2.8 <1.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-112947: 0.50% estimated exploitation activity in the next 30 days; percentile 43.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The first 4 bytes of files outside of server.fs setting can be returned to the browser by a request containing ?vite-wasm-instance. Impact Only apps that match one of the following conditions are affected: - explicitly expose the Vite dev server to the network using --host or the server.host option - there's a file that has a sensitive information in the first 4 bytes - uses Node.js or Deno to run Vite (if Bun is used, it is not affected) Details Requests containing the ?vite-wasm-instance query are handled by the internal Wasm plugin's load hook. The hook removes the query and reads the resulting path directly from disk, but the server.fs checks were not applied. After reading the file, Vite attempts to parse it as WebAssembly. When that parse fails, Node and deno throws an error that contains the first 4 bytes of the file. PoC Create a denied file and start an affected Vite dev server: This will show
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-vfpm-58rq-9qcg
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-vfpm-58rq-9qcg
- Revision 1 · created ·
Published from ghsa record GHSA-vfpm-58rq-9qcg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112947 Advisory: Vite: First 4 bytes of files outside of `server.fs` setting is exposed by `?vite-wasm-instance` IDs: CVE-2026-112947, GHSA-vfpm-58rq-9qcg Record: https://patchnext.com/advisories/cve-2026-112947 (revision 4, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vite 8.3.3, 8.2.4; vite-plus 1.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vite: affected >= 8.3.0, <= 8.3.2; >= 8.2.0, <= 8.2.3; fixed in 8.2.4, 8.3.3 - npm vite-plus: affected >= 0.2.8, <= 1.0.0; fixed in 1.1.0 ## Suggested inspection (read-only) - `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vite-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vite, vite-plus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vfpm-58rq-9qcg (GitHub-reviewed advisory GHSA-vfpm-58rq-9qcg lists affected ranges: npm vite >=8.3.0 =8.2.0 =0.2.8 <=1.0.0) - Verified: https://osv.dev/vulnerability/GHSA-vfpm-58rq-9qcg (OSV record GHSA-vfpm-58rq-9qcg lists affected ranges: npm vite >=8.3.0 =8.2.0 =0.2.8 <1.1.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…