Skip to content

← Actionable
Low, CVSS 2.1amended

Vite: Cross origin script execution through Vite custom middleware

CVE-2026-112945GHSA-9jrq-w75r-8gcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4; vite-plus 1.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vite

    Affected
    >= 8.3.0, <= 8.3.2>= 8.2.0, <= 8.2.3>= 8.0.0, <= 8.1.5>= 7.0.0, <= 7.3.6<= 6.4.3
    Fixed in
    7.3.7, 8.2.4, 8.1.6, 8.3.3, 6.4.4
  • npm vite-plus

    Affected
    <= 1.0.0
    Fixed in
    1.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-112945: 0.67% estimated exploitation activity in the next 30 days; percentile 52.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When accessing a malicious site while a dev server using Vite is running, that site was able to load scripts in a page served by the dev server. Impact Only apps that match the following conditions are affected: - the dev server passes an unchanged browser request URL to server.transformIndexHtml: this is normally used for server.middlewareMode: true or appType: 'custom'. The internal call for appType: 'spa' and appType: 'mpa' does not match this. - the transformed HTML contains an inline module script - from the script in the page served by the dev server, the app stores sensitive values in the location accessible or allows critical actions Details Vite's SSR guide for 8.2.1 documents the affected setup. The application embeds Vite in middleware mode, reads trusted HTML, and passes the browser's unchanged request URL to the transform: For a development server at http://localhost:5173, an attacker can send this URL: In Vite 8.2.1, createDevHtmlTransformFn and getHtmlFilename…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-9jrq-w75r-8gcw

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-9jrq-w75r-8gcw

  4. Revision 1 · created ·

    Published from ghsa record GHSA-9jrq-w75r-8gcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112945

Advisory: Vite: Cross origin script execution through Vite custom middleware
IDs: CVE-2026-112945, GHSA-9jrq-w75r-8gcw
Record: https://patchnext.com/advisories/cve-2026-112945 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vite 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4; vite-plus 1.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vite: affected >= 8.3.0, <= 8.3.2; >= 8.2.0, <= 8.2.3; >= 8.0.0, <= 8.1.5; >= 7.0.0, <= 7.3.6; <= 6.4.3; fixed in 7.3.7, 8.2.4, 8.1.6, 8.3.3, 6.4.4
- npm vite-plus: affected <= 1.0.0; fixed in 1.1.0

## Suggested inspection (read-only)
- `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vite-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vite, vite-plus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9jrq-w75r-8gcw (GitHub-reviewed advisory GHSA-9jrq-w75r-8gcw lists affected ranges: npm vite >=8.3.0 =8.2.0 =8.0.0 =7.0.0 =0 =0 <=1.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-9jrq-w75r-8gcw (OSV record GHSA-9jrq-w75r-8gcw lists affected ranges: npm vite >=8.3.0 =8.2.0 =8.0.0 =7.0.0 =0 =0 <1.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…