Skip to content

← Actionable
Medium, CVSS 6.3amended

launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors

CVE-2026-112944GHSA-r825-w8mm-5pxw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4; vite-plus 1.1.0; launch-editor 2.14.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vite

    Affected
    >= 8.3.0, <= 8.3.2>= 8.2.0, <= 8.2.3>= 8.0.0, <= 8.1.5>= 7.0.0, <= 7.3.6<= 6.4.3
    Fixed in
    7.3.7, 8.2.4, 8.1.6, 8.3.3, 6.4.4
  • npm vite-plus

    Affected
    <= 1.0.0
    Fixed in
    1.1.0
  • npm launch-editor

    Affected
    <= 2.14.1
    Fixed in
    2.14.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-112944: 0.70% estimated exploitation activity in the next 30 days; percentile 53.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary launch-editor forwarded file paths directly to editors without sanitization. If a path resembles a CLI flag, editors like Vim may interpret it as a command, potentially causing unintended file overwrites or command execution. Impact Direct launch-editor users Only apps that match all of the following conditions are affected: - The attacker is able to create a file system entry (e.g. a file or directory) starting with + or - in the working directory - The user uses or the app specifies any of the following editors: - Vim (including gVim) - MacVim - Emacs (including Emacsclient) - Notepad++ (only if using a plugin exposing dangerous operations via plugin messages) - The first argument of launchEditor can start with + or - or the user is using WSL launch-editor-middleware users Only apps that match the following conditions are affected: - The attacker is able to create a file system entry (e.g. a file or directory) starting with + or - in the working directory - The user uses or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-r825-w8mm-5pxw

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-r825-w8mm-5pxw

  4. Revision 1 · created ·

    Published from ghsa record GHSA-r825-w8mm-5pxw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112944

Advisory: launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors
IDs: CVE-2026-112944, GHSA-r825-w8mm-5pxw
Record: https://patchnext.com/advisories/cve-2026-112944 (revision 4, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vite 8.3.3, 8.2.4, 8.1.6, 7.3.7, 6.4.4; vite-plus 1.1.0; launch-editor 2.14.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vite: affected >= 8.3.0, <= 8.3.2; >= 8.2.0, <= 8.2.3; >= 8.0.0, <= 8.1.5; >= 7.0.0, <= 7.3.6; <= 6.4.3; fixed in 7.3.7, 8.2.4, 8.1.6, 8.3.3, 6.4.4
- npm vite-plus: affected <= 1.0.0; fixed in 1.1.0
- npm launch-editor: affected <= 2.14.1; fixed in 2.14.2

## Suggested inspection (read-only)
- `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vite-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls launch-editor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vite, vite-plus, launch-editor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r825-w8mm-5pxw (GitHub-reviewed advisory GHSA-r825-w8mm-5pxw lists affected ranges: npm launch-editor >=0 =8.3.0 =8.2.0 =8.0.0 =7.0.0 =0 =0 <=1.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-r825-w8mm-5pxw (OSV record GHSA-r825-w8mm-5pxw lists affected ranges: npm launch-editor >=0 =8.3.0 =8.2.0 =8.0.0 =7.0.0 =0 =0 <1.1.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…