Pillow: Argument Injection in Ghostscript call, potentially leading into RCE
CVE-2026-112900GHSA-w889-685w-c8fh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 2.6.0, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 2.6.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w889-685w-c8fh lists affected ranges: PyPI pillow >=2.6.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w889-685w-c8fh lists affected ranges: PyPI pillow >=2.6.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-112900 lists affected ranges: Bitnami pillow >=2.6.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-112900: 1.30% estimated exploitation activity in the next 30 days; percentile 70.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary `PIL.EpsImagePlugin.Ghostscript()` builds the Ghostscript command line using the input file path (`fp.name`) without sanitization, placing it at `-f `. A filename beginning with `-` is interpreted by Ghostscript as an option, giving command-line argument injection; chainable to RCE (see Impact). Reproduces with Pillow's default invocation (with `-dSAFER` enabled).
Details _Give all details on the vulnerability. Pointing to the incriminated source code is very helpful for the maintainer._
Type CWE-88 (Argument Injection) (→ CWE-78 (OS Command Injection) optionally, with attacker controlled text file)
Vulnerable Codes ```python infile_temp = None if hasattr(fp, "name") and os.path.exists(fp.name): infile = fp.name
user-controlled path used as-is, without validation else: in_fd, infile_temp = tempfile.mkstemp() os.close(in_fd) infile = infile_temp
... (copy fp into a temporary file)
Build Ghostscript command command = gs_binary, "-q",…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 7 · amended ·
Amended from osv record BIT-pillow-2026-112900
- Revision 6 · amended ·
Amended from ghsa record GHSA-w889-685w-c8fh
- Revision 5 · amended ·
Amended from osv record BIT-pillow-2026-112900
- Revision 4 · amended ·
Amended from osv record GHSA-w889-685w-c8fh
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-w889-685w-c8fh
- Revision 1 · created ·
Published from ghsa record GHSA-w889-685w-c8fh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112900 Advisory: Pillow: Argument Injection in Ghostscript call, potentially leading into RCE IDs: CVE-2026-112900, GHSA-w889-685w-c8fh Record: https://patchnext.com/advisories/cve-2026-112900 (revision 7, source checked 30 Oct 2026, 07:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 2.6.0, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 2.6.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w889-685w-c8fh (GitHub-reviewed advisory GHSA-w889-685w-c8fh lists affected ranges: PyPI pillow >=2.6.0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-w889-685w-c8fh (OSV record GHSA-w889-685w-c8fh lists affected ranges: PyPI pillow >=2.6.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112900 (OSV record BIT-pillow-2026-112900 lists affected ranges: Bitnami pillow >=2.6.0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…