Skip to content

← Actionable
High, CVSS 8.7amended

Pillow: Unbounded recursion parsing a PDF page tree or trailer chain (incomplete fix for CVE-2026-42310)

CVE-2026-112895GHSA-p4wg-p73j-c528

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami pillow

    Affected
    >= 5.1.0, < 13.0.0
    Fixed in
    13.0.0
  • PyPI pillow

    Affected
    >= 5.1.0, < 13.0.0
    Fixed in
    13.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-112895: 0.59% estimated exploitation activity in the next 30 days; percentile 48.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When an application appends to an existing PDF with `Image.save(..., format="PDF", append=True)`, Pillow parses that file with `PdfParser`. Two recursive parsers have no effective bound. `linearize_page_tree` follows `/Kids` with no visited set or depth limit, so a cyclic or duplicated page tree recurses without end. `read_prev_trailer` rejects only an exactly repeated `/Prev` offset, so a long chain of unique offsets still recurses. The trailer-loop guard added for CVE-2026-42310 does not cover either case.

Details `linearize_page_tree` recurses on `/Kids` with no cycle or depth check: - `src/PIL/PdfParser.py:1078-1092` `read_prev_trailer` catches only a repeated offset: - `src/PIL/PdfParser.py:697-720` (the `processed_offsets` check at `:714-718` is the CVE-2026-42310 fix; a unique-offset chain slips past it)

PoC ```python from PIL import PdfParser

A page tree whose /Pages nodes reference each other in a cycle (2 -> 3 -> 2). objs = { 1: b" >", 2: b" >", 3: b"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 7 · amended ·

    Amended from osv record BIT-pillow-2026-112895

  2. Revision 6 · amended ·

    Amended from ghsa record GHSA-p4wg-p73j-c528

  3. Revision 5 · amended ·

    Amended from osv record BIT-pillow-2026-112895

  4. Revision 4 · amended ·

    Amended from osv record GHSA-p4wg-p73j-c528

  5. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  6. Revision 2 · amended ·

    Amended from osv record GHSA-p4wg-p73j-c528

  7. Revision 1 · created ·

    Published from ghsa record GHSA-p4wg-p73j-c528

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112895

Advisory: Pillow: Unbounded recursion parsing a PDF page tree or trailer chain (incomplete fix for CVE-2026-42310)
IDs: CVE-2026-112895, GHSA-p4wg-p73j-c528
Record: https://patchnext.com/advisories/cve-2026-112895 (revision 7, source checked 30 Oct 2026, 07:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami pillow: affected >= 5.1.0, < 13.0.0; fixed in 13.0.0
- PyPI pillow: affected >= 5.1.0, < 13.0.0; fixed in 13.0.0

## Suggested inspection (read-only)
- Bitnami pillow: check the installed version with your package manager.
- `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pillow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p4wg-p73j-c528 (GitHub-reviewed advisory GHSA-p4wg-p73j-c528 lists affected ranges: PyPI pillow >=5.1.0 <13.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-p4wg-p73j-c528 (OSV record GHSA-p4wg-p73j-c528 lists affected ranges: PyPI pillow >=5.1.0 <13.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112895 (OSV record BIT-pillow-2026-112895 lists affected ranges: Bitnami pillow >=5.1.0 <13.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…