Skip to content

← Actionable
High, CVSS 8.7amended

Pillow: MSP RLE decoder expands a tiny file into unbounded memory

CVE-2026-112892GHSA-gg2r-wvfm-q9rx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami pillow

    Affected
    >= 4.1.0, < 13.0.0
    Fixed in
    13.0.0
  • PyPI pillow

    Affected
    >= 4.1.0, < 13.0.0
    Fixed in
    13.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-112892: 0.50% estimated exploitation activity in the next 30 days; percentile 43.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The MSP RLE decoder expands run-length data into an in-memory buffer with no cap tied to the declared image size. A small file that passes the pixel-count check can force hundreds of megabytes or more of allocation when the application loads pixels.

Details The MSP decoder writes each run into an unbounded `io.BytesIO` and can expand roughly 85x per run: - `src/PIL/MspImagePlugin.py:144-146`

Impact Memory-exhaustion denial of service from a tiny crafted image in any application that loads pixels. The expansion is decoupled from the declared pixel count, so `MAX_IMAGE_PIXELS` does not bound it.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 7 · amended ·

    Amended from osv record BIT-pillow-2026-112892

  2. Revision 6 · amended ·

    Amended from ghsa record GHSA-gg2r-wvfm-q9rx

  3. Revision 5 · amended ·

    Amended from osv record BIT-pillow-2026-112892

  4. Revision 4 · amended ·

    Amended from osv record GHSA-gg2r-wvfm-q9rx

  5. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  6. Revision 2 · amended ·

    Amended from osv record GHSA-gg2r-wvfm-q9rx

  7. Revision 1 · created ·

    Published from ghsa record GHSA-gg2r-wvfm-q9rx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112892

Advisory: Pillow: MSP RLE decoder expands a tiny file into unbounded memory
IDs: CVE-2026-112892, GHSA-gg2r-wvfm-q9rx
Record: https://patchnext.com/advisories/cve-2026-112892 (revision 7, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami pillow: affected >= 4.1.0, < 13.0.0; fixed in 13.0.0
- PyPI pillow: affected >= 4.1.0, < 13.0.0; fixed in 13.0.0

## Suggested inspection (read-only)
- Bitnami pillow: check the installed version with your package manager.
- `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pillow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gg2r-wvfm-q9rx (GitHub-reviewed advisory GHSA-gg2r-wvfm-q9rx lists affected ranges: PyPI pillow >=4.1.0 <13.0.0)
- Verified: https://osv.dev/vulnerability/GHSA-gg2r-wvfm-q9rx (OSV record GHSA-gg2r-wvfm-q9rx lists affected ranges: PyPI pillow >=4.1.0 <13.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112892 (OSV record BIT-pillow-2026-112892 lists affected ranges: Bitnami pillow >=4.1.0 <13.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…