Skip to content

← Actionable
Low, CVSS 2.3

Parse Server before 8.6.98 and 9.x before 9.10.3 Session Class-Level Permission Bypass

CVE-2026-112769GHSA-gj37-5hg5-p729

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse 9.10.3, 8.6.98), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami parse

    Affected
    < 8.6.98>= 9.0.0, < 9.10.3
    Fixed in
    9.10.3, 8.6.98

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
EPSS
  • CVE-2026-112769: 0.32% estimated exploitation activity in the next 30 days; percentile 25.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Parse Server before 8.6.98 and 9.0.0 before 9.10.3 does not enforce the create and addField class-level permissions of the _Session class when creating sessions. An authenticated user, or anyone holding that user's session token, can send POST requests to /sessions or /classes/_Session to create additional sessions for that user and add fields to _Session; these sessions are not revoked when the original session is logged out.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record BIT-parse-2026-112769

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112769

Advisory: Parse Server before 8.6.98 and 9.x before 9.10.3 Session Class-Level Permission Bypass
IDs: CVE-2026-112769, GHSA-gj37-5hg5-p729
Record: https://patchnext.com/advisories/cve-2026-112769 (revision 1, source checked 26 Oct 2026, 12:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parse 9.10.3, 8.6.98. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami parse: affected < 8.6.98; >= 9.0.0, < 9.10.3; fixed in 9.10.3, 8.6.98

## Suggested inspection (read-only)
- Bitnami parse: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/BIT-parse-2026-112769 (OSV record BIT-parse-2026-112769 lists affected ranges: Bitnami parse >=0 =9.0.0 <9.10.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…