Pillow: NULL pointer dereference in Image.merge via an unvalidated band 0
CVE-2026-112405GHSA-cp9v-662q-vvx9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 12.0.0, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 12.0.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cp9v-662q-vvx9 lists affected ranges: PyPI pillow >=12.0.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cp9v-662q-vvx9 lists affected ranges: PyPI pillow >=12.0.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-112405 lists affected ranges: Bitnami pillow >=12.0.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4333 lists affected ranges: PyPI pillow >=12.0.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-112405: 0.59% estimated exploitation activity in the next 30 days; percentile 48.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary `Image.merge()` checks the mode of every input band except band 0. If band 0 is a single-band `I` or `F` image, the native merge routine reads a pixel pointer that is NULL for those modes and the process crashes. The IPTC plugin reaches this from a plain `Image.open()` followed by a load, and IPTC has no magic-byte prefilter, so a crafted file with no recognizable header can drive it.
Details The validation loop skips band 0: - `src/PIL/Image.py:3795` iterates `for band in bands[1:]` and checks mode and size only for those. For an `I` or `F` image the 8-bit plane `image8` is NULL (only `image32` is set). `ImagingMerge` dereferences `bands[0]->image8[y]` for the multi-band output modes: - `src/libImaging/Bands.c:302`, `:311`, `:321` The IPTC loader builds the band list from an attacker-typed sub-image and passes it to merge with the sub-image at index 0: - `src/PIL/IptcImagePlugin.py:156-160` - `src/PIL/IptcImagePlugin.py:169` registers the opener with no accept…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 10 · amended ·
Amended from osv record BIT-pillow-2026-112405
- Revision 9 · amended ·
Amended from osv record BIT-pillow-2026-112405
- Revision 8 · amended ·
Amended from osv record PYSEC-2026-4333
- Revision 7 · amended ·
Amended from osv record GHSA-cp9v-662q-vvx9
- Revision 6 · amended ·
Amended from ghsa record GHSA-cp9v-662q-vvx9
- Revision 5 · amended ·
Amended from osv record BIT-pillow-2026-112405
- Revision 4 · amended ·
Amended from osv record GHSA-cp9v-662q-vvx9
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-cp9v-662q-vvx9
- Revision 1 · created ·
Published from ghsa record GHSA-cp9v-662q-vvx9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112405 Advisory: Pillow: NULL pointer dereference in Image.merge via an unvalidated band 0 IDs: CVE-2026-112405, GHSA-cp9v-662q-vvx9 Record: https://patchnext.com/advisories/cve-2026-112405 (revision 10, source checked 30 Oct 2026, 07:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 12.0.0, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 12.0.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cp9v-662q-vvx9 (GitHub-reviewed advisory GHSA-cp9v-662q-vvx9 lists affected ranges: PyPI pillow >=12.0.0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-cp9v-662q-vvx9 (OSV record GHSA-cp9v-662q-vvx9 lists affected ranges: PyPI pillow >=12.0.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112405 (OSV record BIT-pillow-2026-112405 lists affected ranges: Bitnami pillow >=12.0.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4333 (OSV record PYSEC-2026-4333 lists affected ranges: PyPI pillow >=12.0.0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…