Skip to content

← Actionable
Critical, CVSS 9.2amended

Pillow: Heap buffer overflow in FlashPix (FPX) JPEG decoding leads to code execution

CVE-2026-112398GHSA-5x8w-8jj5-q52h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Bitnami pillow

    Affected
    < 13.0.0
    Fixed in
    13.0.0
  • PyPI pillow

    Affected
    < 13.0.0
    Fixed in
    13.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-112398: 0.70% estimated exploitation activity in the next 30 days; percentile 53.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Credits Researcher: Alex Bouffard (mixbo@pebwalker.com)

Summary A heap buffer overflow in Pillow's FlashPix (FPX) JPEG-tile decoder lets an attacker achieve arbitrary code execution by getting an application to open a single crafted file with `Image.open()`. The file is recognized by content (the OLE2 magic), not by extension, so any service that opens or thumbnails untrusted uploads with the optional `olefile` dependency installed is reachable with no user interaction. In the PoC below, opening one crafted file executes an attacker-chosen command on stock Pillow 12.2.0 (x86_64 Ubuntu 24.04, glibc 2.39).

Details `FpxImagePlugin` decodes FlashPix (FPX) files, which are OLE2/CFBF compound documents. `Image.open()` auto-detects them from the OLE2 magic `D0CF11E0...` whenever the optional `olefile` package is installed (Pillow's documented dependency for FPX/MIC support), regardless of the file's extension. For a JPEG-compressed subimage (`compression == 2`), the plugin…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 11 · amended ·

    Amended from osv record BIT-pillow-2026-112398

  2. Revision 10 · amended ·

    Amended from osv record BIT-pillow-2026-112398

  3. Revision 9 · amended ·

    Amended from osv record PYSEC-2026-4330

  4. Revision 8 · amended ·

    Amended from osv record GHSA-5x8w-8jj5-q52h

  5. Revision 7 · amended ·

    Amended from ghsa record GHSA-5x8w-8jj5-q52h

  6. Revision 6 · amended ·

    Amended from osv record BIT-pillow-2026-112398

  7. Revision 5 · amended ·

    Amended from osv record GHSA-5x8w-8jj5-q52h

  8. Revision 4 · amended ·

    Amended from ghsa record GHSA-5x8w-8jj5-q52h

  9. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  10. Revision 2 · amended ·

    Amended from osv record GHSA-5x8w-8jj5-q52h

  11. Revision 1 · created ·

    Published from ghsa record GHSA-5x8w-8jj5-q52h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-112398

Advisory: Pillow: Heap buffer overflow in FlashPix (FPX) JPEG decoding leads to code execution
IDs: CVE-2026-112398, GHSA-5x8w-8jj5-q52h
Record: https://patchnext.com/advisories/cve-2026-112398 (revision 11, source checked 30 Oct 2026, 07:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Bitnami pillow: affected < 13.0.0; fixed in 13.0.0
- PyPI pillow: affected < 13.0.0; fixed in 13.0.0

## Suggested inspection (read-only)
- Bitnami pillow: check the installed version with your package manager.
- `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pillow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5x8w-8jj5-q52h (GitHub-reviewed advisory GHSA-5x8w-8jj5-q52h lists affected ranges: PyPI pillow >=0 <=12.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-5x8w-8jj5-q52h (OSV record GHSA-5x8w-8jj5-q52h lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112398 (OSV record BIT-pillow-2026-112398 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2026-4330 (OSV record PYSEC-2026-4330 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…