Pillow: Heap use-after-free when encoding TIFF to an in-memory buffer
CVE-2026-112396GHSA-4rr5-89j8-mwwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 11.3.0, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 11.3.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4rr5-89j8-mwwm lists affected ranges: PyPI pillow >=11.3.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4rr5-89j8-mwwm lists affected ranges: PyPI pillow >=11.3.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-112396 lists affected ranges: Bitnami pillow >=11.3.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4328 lists affected ranges: PyPI pillow >=11.3.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-112396: 0.69% estimated exploitation activity in the next 30 days; percentile 53.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Saving an image as TIFF to an in-memory buffer can trigger a heap use-after-free if libtiff rejects a tag at encode time. When `TIFFWriteScanline` fails, the encoder frees its output buffer but leaves the libtiff handle open. Later, when the encoder object is torn down, `TIFFClose` flushes buffered bytes through the write callback and writes into the freed buffer. An application that re-encodes attacker-influenced images to TIFF in memory can be crashed and is a candidate for remote code execution.
Details The failure path in `ImagingLibTiffEncode` frees `clientstate->data` for the in-memory case but does not close the TIFF or null `clientstate->tiff` (the file-descriptor branch just above it does set `tiff = NULL`): - `src/libImaging/TiffDecode.c:1041-1046` Teardown then calls `ImagingLibTiffEncodeCleanup`, which runs `TIFFClose(tiff)` because `tiff` is still set: - `src/encode.c:99-101` - `src/libImaging/TiffDecode.c:955` `TIFFClose` flushes through…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 8 · amended ·
Amended from osv record BIT-pillow-2026-112396
- Revision 7 · amended ·
Amended from osv record PYSEC-2026-4328
- Revision 6 · amended ·
Amended from osv record GHSA-4rr5-89j8-mwwm
- Revision 5 · amended ·
Amended from ghsa record GHSA-4rr5-89j8-mwwm
- Revision 4 · amended ·
Amended from osv record BIT-pillow-2026-112396
- Revision 3 · amended ·
Amended from osv record GHSA-4rr5-89j8-mwwm
- Revision 2 · amended ·
Amended from osv record GHSA-4rr5-89j8-mwwm
- Revision 1 · created ·
Published from ghsa record GHSA-4rr5-89j8-mwwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112396 Advisory: Pillow: Heap use-after-free when encoding TIFF to an in-memory buffer IDs: CVE-2026-112396, GHSA-4rr5-89j8-mwwm Record: https://patchnext.com/advisories/cve-2026-112396 (revision 8, source checked 28 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 11.3.0, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 11.3.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4rr5-89j8-mwwm (GitHub-reviewed advisory GHSA-4rr5-89j8-mwwm lists affected ranges: PyPI pillow >=11.3.0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-4rr5-89j8-mwwm (OSV record GHSA-4rr5-89j8-mwwm lists affected ranges: PyPI pillow >=11.3.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112396 (OSV record BIT-pillow-2026-112396 lists affected ranges: Bitnami pillow >=11.3.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4328 (OSV record PYSEC-2026-4328 lists affected ranges: PyPI pillow >=11.3.0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…