Pillow: P;2L and P;4L decoders may read 1 to 3 bytes past the passed buffer size
CVE-2026-112394GHSA-4558-3h8r-v8xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4558-3h8r-v8xp lists affected ranges: PyPI pillow >=0 <=12.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4558-3h8r-v8xp lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-112394 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-4327 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-112394: 0.56% estimated exploitation activity in the next 30 days; percentile 46.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary On `main`, even with the guard in #9725, it's possible to have these decoders read 1 to 3 bytes past the end of the passed buffer with a suitable width/height.
Details `ImagingRawDecode` and the `P;2L` / `P;4L` unpackers disagree about how many bytes a line of data occupies. The raw decoder derives the line size from the bits per pixel ```c state->bytes = (state->xsize * state->bits + 7) / 8; ``` and uses it both for the bounds check and to advance to the next line. For `P;2L` and `P;4L`, `bits` is 2 and 4 respectively. But these two rawmodes are not packed pixels but 2 or 4 *bit planes*, each padded to a whole number of bytes. `unpackP2L` computes `s = (pixels + 7) / 8` and reads plane *k* at offset `k * s`, and `unpackP4L` does the same across four planes. Their real footprint is therefore `planes * ((xsize + 7) / 8)`. For some widths, padding each plane separately makes this footprint larger than `state->bytes`. For example, at width 1, the decoder accounts for one…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 9 · amended ·
Amended from osv record BIT-pillow-2026-112394
- Revision 8 · amended ·
Amended from osv record PYSEC-2026-4327
- Revision 7 · amended ·
Amended from osv record GHSA-4558-3h8r-v8xp
- Revision 6 · amended ·
Amended from ghsa record GHSA-4558-3h8r-v8xp
- Revision 5 · amended ·
Amended from osv record BIT-pillow-2026-112394
- Revision 4 · amended ·
Amended from osv record GHSA-4558-3h8r-v8xp
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-4558-3h8r-v8xp
- Revision 1 · created ·
Published from ghsa record GHSA-4558-3h8r-v8xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112394 Advisory: Pillow: P;2L and P;4L decoders may read 1 to 3 bytes past the passed buffer size IDs: CVE-2026-112394, GHSA-4558-3h8r-v8xp Record: https://patchnext.com/advisories/cve-2026-112394 (revision 9, source checked 28 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4558-3h8r-v8xp (GitHub-reviewed advisory GHSA-4558-3h8r-v8xp lists affected ranges: PyPI pillow >=0 <=12.3.0) - Verified: https://osv.dev/vulnerability/GHSA-4558-3h8r-v8xp (OSV record GHSA-4558-3h8r-v8xp lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112394 (OSV record BIT-pillow-2026-112394 lists affected ranges: Bitnami pillow >=0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-4327 (OSV record PYSEC-2026-4327 lists affected ranges: PyPI pillow >=0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…