Pillow: PdfParser can recurse without limit in get_value() and linearize_page_tree()
CVE-2026-112391GHSA-254f-3936-288h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 13.0.0; pillow 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Bitnami pillow
- Affected
- >= 5.1.0, < 13.0.0
- Fixed in
- 13.0.0
PyPI pillow
- Affected
- >= 5.1.0, < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-254f-3936-288h lists affected ranges: PyPI pillow >=5.1.0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-254f-3936-288h lists affected ranges: PyPI pillow >=5.1.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record BIT-pillow-2026-112391 lists affected ranges: Bitnami pillow >=5.1.0 <13.0.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-112391: 0.58% estimated exploitation activity in the next 30 days; percentile 47.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary `PdfParser`'s `get_value()` can recurse without any limit and crash with an uncaught `RecursionError`. It is reachable through `Image.save(im, fp= , format="PDF", append=True)` when the existing PDF file is attacker-controlled. This is the same class of bug as https://github.com/advisories/GHSA-r73j-pqj5-w3x7 (the /Prev trailer chain loop, fixed earlier this year), in the same file, but in two different functions that fix did not touch.
Details `get_value()` in `src/PIL/PdfParser.py` This is a classmethod that takes `max_nesting: int = -1` and has a guard: ```python if max_nesting == 0: return None, None ``` Every recursive call (nested arrays, dictionaries, indirect object definitions) passes `max_nesting=max_nesting - 1`. Since the default and every call site start at -1, this only ever counts down further negative: -1, -2, -3, and so on. It never equals exactly 0, so the guard never runs. A PDF object with a value nested a few thousand levels deep is enough to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 6 · amended ·
Amended from ghsa record GHSA-254f-3936-288h
- Revision 5 · amended ·
Amended from osv record BIT-pillow-2026-112391
- Revision 4 · amended ·
Amended from osv record GHSA-254f-3936-288h
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-254f-3936-288h
- Revision 1 · created ·
Published from ghsa record GHSA-254f-3936-288h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-112391 Advisory: Pillow: PdfParser can recurse without limit in get_value() and linearize_page_tree() IDs: CVE-2026-112391, GHSA-254f-3936-288h Record: https://patchnext.com/advisories/cve-2026-112391 (revision 6, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 13.0.0; pillow 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Bitnami pillow: affected >= 5.1.0, < 13.0.0; fixed in 13.0.0 - PyPI pillow: affected >= 5.1.0, < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Bitnami pillow: check the installed version with your package manager. - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-254f-3936-288h (GitHub-reviewed advisory GHSA-254f-3936-288h lists affected ranges: PyPI pillow >=5.1.0 <13.0.0) - Verified: https://osv.dev/vulnerability/GHSA-254f-3936-288h (OSV record GHSA-254f-3936-288h lists affected ranges: PyPI pillow >=5.1.0 <13.0.0 (fixed)) - Verified: https://osv.dev/vulnerability/BIT-pillow-2026-112391 (OSV record BIT-pillow-2026-112391 lists affected ranges: Bitnami pillow >=5.1.0 <13.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…