Vikunja: Write-level project members can delete admin-tier link shares through an unloaded permission check
CVE-2026-111921GHSA-fmmf-xq98-g327
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.vikunja.io/api 2.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.13.0, < 2.7.0
- Fixed in
- 2.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6730 lists affected ranges: Go code.vikunja.io/api >=0
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fmmf-xq98-g327 lists affected ranges: Go code.vikunja.io/api >=0.13.0 <=2.6.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmmf-xq98-g327 lists affected ranges: Go code.vikunja.io/api >=0.13.0 <=2.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fmmf-xq98-g327 lists affected ranges: Go code.vikunja.io/api >=0.13.0 <2.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-111921: 0.21% estimated exploitation activity in the next 30 days; percentile 11.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A project member with Write permission can delete an admin-tier link share on that project. The deletion authorization check reads the permission from an object populated only with URL IDs, rather than from the stored share. Its zero value is Read, so the check falls through to project Write permission instead of requiring Admin.
Details Affected endpoints: - `DELETE /api/v1/projects/{project}/shares/{share}` - `DELETE /api/v2/projects/{project}/shares/{share}` Older v1 releases used `/lists/{list}/shares/{share}` before lists were renamed to projects. In `pkg/routes/api/v2/link_sharing.go:156`, the delete handler passes `&models.LinkSharing{ID: in.ID, ProjectID: in.ProjectID}` to `handler.DoDelete`. The v1 generic handler likewise binds the URL IDs without loading the stored share. `pkg/web/handler/core.go:185` calls `CanDelete` before `Delete`. `LinkSharing.CanDelete` delegates to `canDoLinkShare` in `pkg/models/link_sharing_permissions.go`. That helper loads the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 6 · amended ·
Amended from osv record GHSA-fmmf-xq98-g327
- Revision 5 · amended ·
Amended from ghsa record GHSA-fmmf-xq98-g327
- Revision 4 · amended ·
Amended from ghsa record GHSA-fmmf-xq98-g327
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GO-2026-6730
- Revision 1 · created ·
Published from osv record GHSA-fmmf-xq98-g327
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-111921 Advisory: Vikunja: Write-level project members can delete admin-tier link shares through an unloaded permission check IDs: CVE-2026-111921, GHSA-fmmf-xq98-g327 Record: https://patchnext.com/advisories/cve-2026-111921 (revision 6, source checked 28 Oct 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code.vikunja.io/api 2.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go code.vikunja.io/api: affected >= 0.13.0, < 2.7.0; fixed in 2.7.0 ## Suggested inspection (read-only) - Go code.vikunja.io/api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code.vikunja.io/api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GO-2026-6730 (OSV record GO-2026-6730 lists affected ranges: Go code.vikunja.io/api >=0) - Verified: https://osv.dev/vulnerability/GHSA-fmmf-xq98-g327 (OSV record GHSA-fmmf-xq98-g327 lists affected ranges: Go code.vikunja.io/api >=0.13.0 <=2.6.0) - Verified: https://github.com/advisories/GHSA-fmmf-xq98-g327 (GitHub-reviewed advisory GHSA-fmmf-xq98-g327 lists affected ranges: Go code.vikunja.io/api >=0.13.0 <=2.6.0) - Verified: https://osv.dev/vulnerability/GHSA-fmmf-xq98-g327 (OSV record GHSA-fmmf-xq98-g327 lists affected ranges: Go code.vikunja.io/api >=0.13.0 <2.7.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…