MCP TypeScript SDK: Server bearer authentication accepted tokens issued for another service
CVE-2026-111771GHSA-rvq5-wwqv-78pq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@modelcontextprotocol/sdk 1.32.0; @modelcontextprotocol/server 2.3.0; @modelcontextprotocol/server-legacy 2.3.1; @modelcontextprotocol/express 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.6.0, < 1.32.0
- Fixed in
- 1.32.0
npm @modelcontextprotocol/server
- Affected
- >= 2.0.0, < 2.3.0
- Fixed in
- 2.3.0
npm @modelcontextprotocol/server-legacy
- Affected
- >= 2.0.0, < 2.3.1
- Fixed in
- 2.3.1
npm @modelcontextprotocol/express
- Affected
- >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rvq5-wwqv-78pq lists affected ranges: npm @modelcontextprotocol/sdk >=1.6.0 =2.0.0 =2.0.0 =2.0.0 <2.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rvq5-wwqv-78pq lists affected ranges: npm @modelcontextprotocol/sdk >=1.6.0 =2.0.0 =2.0.0 =2.0.0 <2.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary In affected versions, the SDK's server-side bearer authentication had no way to check that a token was issued for your server (its audience). Where one authorization server issues tokens for several services, a valid token for another service was also accepted by your MCP server. Am I affected? Yes, if your HTTP server uses requireBearerAuth() or verifyBearerToken(), its authorization server also issues tokens for other services, and your verifyAccessToken() does not check the token's audience (aud) itself. Affected versions: - @modelcontextprotocol/sdk 1.6.0 through 1.31.0 - @modelcontextprotocol/server 2.0.0 through 2.2.0 - @modelcontextprotocol/express 2.0.0 through 2.0.1 - @modelcontextprotocol/server-legacy 2.0.0 through 2.3.0 Fix Upgrade to: - 1.x: @modelcontextprotocol/sdk 1.32.0 or later - 2.x: @modelcontextprotocol/server 2.3.0 or later, together with @modelcontextprotocol/express 2.0.2 or later if you use it - @modelcontextprotocol/server-legacy 2.3.1 or later…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rvq5-wwqv-78pq
- Revision 2 · amended ·
Amended from osv record GHSA-rvq5-wwqv-78pq
- Revision 1 · created ·
Published from ghsa record GHSA-rvq5-wwqv-78pq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-111771 Advisory: MCP TypeScript SDK: Server bearer authentication accepted tokens issued for another service IDs: CVE-2026-111771, GHSA-rvq5-wwqv-78pq Record: https://patchnext.com/advisories/cve-2026-111771 (revision 3, source checked 26 Oct 2026, 13:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @modelcontextprotocol/sdk 1.32.0; @modelcontextprotocol/server 2.3.0; @modelcontextprotocol/server-legacy 2.3.1; @modelcontextprotocol/express 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @modelcontextprotocol/sdk: affected >= 1.6.0, < 1.32.0; fixed in 1.32.0 - npm @modelcontextprotocol/server: affected >= 2.0.0, < 2.3.0; fixed in 2.3.0 - npm @modelcontextprotocol/server-legacy: affected >= 2.0.0, < 2.3.1; fixed in 2.3.1 - npm @modelcontextprotocol/express: affected >= 2.0.0, < 2.0.2; fixed in 2.0.2 ## Suggested inspection (read-only) - `npm ls @modelcontextprotocol/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @modelcontextprotocol/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @modelcontextprotocol/server-legacy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @modelcontextprotocol/express --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @modelcontextprotocol/sdk, @modelcontextprotocol/server, @modelcontextprotocol/server-legacy, @modelcontextprotocol/express. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rvq5-wwqv-78pq (GitHub-reviewed advisory GHSA-rvq5-wwqv-78pq lists affected ranges: npm @modelcontextprotocol/sdk >=1.6.0 =2.0.0 =2.0.0 =2.0.0 <2.3.1) - Verified: https://osv.dev/vulnerability/GHSA-rvq5-wwqv-78pq (OSV record GHSA-rvq5-wwqv-78pq lists affected ranges: npm @modelcontextprotocol/sdk >=1.6.0 =2.0.0 =2.0.0 =2.0.0 <2.3.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…