Skip to content

← Actionable
High, CVSS 7.5amended

MCP TypeScript SDK: One HTTP request within the default size limit could exhaust server memory during validation

CVE-2026-111768GHSA-46jr-4wx8-v453

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@modelcontextprotocol/sdk 1.32.0; @modelcontextprotocol/server 2.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary In affected versions, servers put no limit on how many array elements and object keys they validated in one request. One HTTP request within the default 4 MiB size limit could exhaust the server's memory, and the process aborted with JavaScript heap out of memory. No credentials are needed, unless you authenticate requests before they reach the SDK. Am I affected? Yes, if clients you do not fully trust can reach your server over HTTP. The risk is highest for McpServer tools whose input contains an array or a record. stdio-only servers are not affected. Affected versions: - @modelcontextprotocol/sdk 1.3.0 through 1.31.0 - @modelcontextprotocol/server 2.0.0 through 2.2.0 Fix Upgrade to: - 1.x: @modelcontextprotocol/sdk 1.32.0 or later - 2.x: @modelcontextprotocol/server 2.3.0 or later Upgrading alone changes nothing. The patched versions add an McpServer option, maxToolInputElements, that is off by default. Make both of these changes: 1. Set maxToolInputElements just above the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-46jr-4wx8-v453

  2. Revision 2 · amended ·

    Amended from osv record GHSA-46jr-4wx8-v453

  3. Revision 1 · created ·

    Published from ghsa record GHSA-46jr-4wx8-v453

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-111768

Advisory: MCP TypeScript SDK: One HTTP request within the default size limit could exhaust server memory during validation
IDs: CVE-2026-111768, GHSA-46jr-4wx8-v453
Record: https://patchnext.com/advisories/cve-2026-111768 (revision 3, source checked 26 Oct 2026, 13:07 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @modelcontextprotocol/sdk 1.32.0; @modelcontextprotocol/server 2.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @modelcontextprotocol/sdk: affected >= 1.3.0, < 1.32.0; fixed in 1.32.0
- npm @modelcontextprotocol/server: affected >= 2.0.0, < 2.3.0; fixed in 2.3.0

## Suggested inspection (read-only)
- `npm ls @modelcontextprotocol/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @modelcontextprotocol/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @modelcontextprotocol/sdk, @modelcontextprotocol/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-46jr-4wx8-v453 (GitHub-reviewed advisory GHSA-46jr-4wx8-v453 lists affected ranges: npm @modelcontextprotocol/sdk >=1.3.0 =2.0.0 <2.3.0)
- Verified: https://osv.dev/vulnerability/GHSA-46jr-4wx8-v453 (OSV record GHSA-46jr-4wx8-v453 lists affected ranges: npm @modelcontextprotocol/sdk >=1.3.0 =2.0.0 <2.3.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…